Bug 245299 - multimedia/obs-studio: An unspecified error occurred while recording
Summary: multimedia/obs-studio: An unspecified error occurred while recording
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Yuri Victorovich
URL:
Keywords: needs-qa, regression
: 245394 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-02 22:22 UTC by Keith Hellman
Modified: 2020-04-06 20:33 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (yuri)


Attachments
tarball of mentioned attachments (12.50 KB, application/x-tar)
2020-04-02 22:22 UTC, Keith Hellman
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Keith Hellman 2020-04-02 22:22:54 UTC
Created attachment 212994 [details]
tarball of mentioned attachments

Both svn rev 530452 (built on same machine as the defect, with an updated ports tree) and the current package obs-studio-25.0.0_1 failed to record to disk,
providing a very vague error message (attached image and console snip).

I tracked this down with truss to see that obs-ffmpeg-mux was somehow not being provided in the execve call (it is installed alongside obs in /usr/local/bin), attached see truss.out snippet.

I confirmed this was the issue by writing a tiny sh wrapper (attached, obssh.c)
that looked for this particularly malformed invocation of /bin/sh and fixing it before chaining to the true sh (now copied to /bin/sh_).

With either the svn build or the bsd repo package I can easily reproduce or fix this issue depending on which executable (the true /bin/sh or /bin/obssh) is at the /bin/sh path.

I did look at the obs code base, but couldn't easily find where the filename was being lost, sorry.  I was under the gun to get this working for remote lectures I have to deliver.

Thanks for maintaining the obs-studio port.
Comment 1 commit-hook freebsd_committer 2020-04-02 23:43:14 UTC
A commit references this bug:

Author: yuri
Date: Thu Apr  2 23:42:36 UTC 2020
New revision: 530454
URL: https://svnweb.freebsd.org/changeset/ports/530454

Log:
  multimedia/obs-studio: Fix the procfs(5) link for the executable path: /proc/self/exe -> /proc/curproc/file

  PR:		245299
  Reported by:	Keith Hellman <khellman@mcprogramming.com> (the reported issue seems to be the same)

Changes:
  head/multimedia/obs-studio/Makefile
  head/multimedia/obs-studio/files/patch-UI_window-basic-main.cpp
  head/multimedia/obs-studio/files/patch-libobs_util_platform-nix.c
Comment 2 Yuri Victorovich freebsd_committer 2020-04-02 23:45:19 UTC
(In reply to Keith Hellman from comment #0)

Hi Keith,

Thank you for your report.

I found the bug that I strongly suspect has caused the problem that you reported.

Please update the port, try again, and let me know if the problem is fixed.


Yuri
Comment 3 commit-hook freebsd_committer 2020-04-03 09:26:58 UTC
A commit references this bug:

Author: yuri
Date: Fri Apr  3 09:26:09 UTC 2020
New revision: 530477
URL: https://svnweb.freebsd.org/changeset/ports/530477

Log:
  MFH: r530454

  multimedia/obs-studio: Fix the procfs(5) link for the executable path: /proc/self/exe -> /proc/curproc/file

  PR:		245299
  Reported by:	Keith Hellman <khellman@mcprogramming.com> (the reported issue seems to be the same)

  Approved by:	ports-secteam@FreeBSD.org

Changes:
_U  branches/2020Q2/
  branches/2020Q2/multimedia/obs-studio/Makefile
  branches/2020Q2/multimedia/obs-studio/files/patch-UI_window-basic-main.cpp
  branches/2020Q2/multimedia/obs-studio/files/patch-libobs_util_platform-nix.c
Comment 4 Yuri Victorovich freebsd_committer 2020-04-04 22:00:29 UTC
I believe that this bug is now fixed.

Please reopen if you are still experiencing the problem.

Thank you for your report!
Comment 5 Edward Tomasz Napierala freebsd_committer 2020-04-06 16:20:09 UTC
A better fix would be to use KERN_PROC_PATHNAME (https://stackoverflow.com/questions/799679/programmatically-retrieving-the-absolute-path-of-an-os-x-command-line-app); this would get rid of dependency on procfs, which is obsolete.
Comment 6 Ka Ho Ng 2020-04-06 17:24:36 UTC
(In reply to Edward Tomasz Napierala from comment #5)

I proposed another fix to this problem in https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=245403 . Please review it and see if it is good to go.

Ka Ho
Comment 7 Yuri Victorovich freebsd_committer 2020-04-06 18:59:17 UTC
*** Bug 245394 has been marked as a duplicate of this bug. ***
Comment 8 Edward Tomasz Napierala freebsd_committer 2020-04-06 20:33:33 UTC
(In reply to Ka Ho Ng from comment #6)

I see it's already committed, but in any case: looks perfect, thank you!