Bug 245303 - [Coreboot] memstick.img not booting
Summary: [Coreboot] memstick.img not booting
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: misc (show other bugs)
Version: 12.1-STABLE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-02 23:37 UTC by baylee4
Modified: 2020-04-02 23:47 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description baylee4 2020-04-02 23:37:51 UTC
Hi,

I tried to install FreeBSD on a Corebooted machine (using SeaBIOS payload) and it seems that the installer just won’t boot at all. With the 12.x version of the installer hangs just after ‘/boot/entropy size=0x1000’, and with the 11.x version it hangs after ‘Booting…’.

I tried to disable ACPI and enable Verbose in boot options, with similar result. Windows, Linux, and OpenBSD boot just fine on this machine.

It seems that it’s a graphic issue, I tried various combinations of Coreboot settings and here are the results :

GENERIC_LINEAR_FRAMEBUFFER (Linear “high-resolution” framebuffer) : no display at all

VGA_TEXT_FRAMEBUFFER (Legacy VGA text mode) : display, but with altered colors

Does someone have an idea on how to fix this ?

Thank you