Bug 245315 - emulators/emu64: fix build on PPC and ARM
Summary: emulators/emu64: fix build on PPC and ARM
Status: Closed DUPLICATE of bug 245200
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Piotr Kubaj
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-03 11:42 UTC by Piotr Kubaj
Modified: 2020-04-03 12:12 UTC (History)
1 user (show)

See Also:
felix: maintainer-feedback+


Attachments
patch (1.49 KB, patch)
2020-04-03 11:42 UTC, Piotr Kubaj
pkubaj: maintainer-approval? (felix)
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2020-04-03 11:42:10 UTC
Created attachment 213015 [details]
patch

chars on PPC and ARM are unsigned by default.
This causes a build error:
../../emu64-5.0.18/src/c64_class.cpp: In member function 'void C64Class::AnalyzeSDLEvent(SDL_Event*)':
../../emu64-5.0.18/src/c64_class.cpp:1760:46: error: narrowing conversion of '-1' from 'int' to 'char' [-Wnarrowing]
 1760 |     static char joy_axis_tbl[5] = {1,1,0,0,-1};
Comment 1 Felix Palmen 2020-04-03 11:59:00 UTC
Hi Piotr,

this is the same bug as https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=245200 and your patch corresponds to the change the upstream author did in response to https://github.com/ThKattanek/emu64/issues/191 -- so this looks fine.

I assume the emulator works with this patch applied?

Best regards, Felix
Comment 2 Piotr Kubaj freebsd_committer 2020-04-03 12:12:09 UTC
Oh, I didn't notice this bug, thanks!

*** This bug has been marked as a duplicate of bug 245200 ***