Bug 245320 - math/openblas: libopenblas.so does not have a SONAME
Summary: math/openblas: libopenblas.so does not have a SONAME
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thierry Thomas
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-03 16:21 UTC by Thierry Thomas
Modified: 2020-04-04 09:12 UTC (History)
1 user (show)

See Also:
phd_kimberlite: maintainer-feedback+


Attachments
Adding a SONAME to libopenblas.so (1.38 KB, patch)
2020-04-03 16:21 UTC, Thierry Thomas
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Thomas freebsd_committer 2020-04-03 16:21:09 UTC
Created attachment 213021 [details]
Adding a SONAME to libopenblas.so

Trying to link a program with -lopenblas in developer mode produces the following error:

Error: xxx is linked to /usr/local/lib/libopenblas.so which does not have a SONAME.  math/openblas needs to be fixed.

The attached patch adds a soname to this lib.

Note: `ldconfig -r` still did not list it, this is caused by its naming scheme, and this is not fixed by the proposed patch.
Comment 1 Thierry Thomas freebsd_committer 2020-04-04 09:03:31 UTC
Committed, thanks for your quick feedback!
Comment 2 commit-hook freebsd_committer 2020-04-04 09:12:52 UTC
A commit references this bug:

Author: thierry
Date: Sat Apr  4 09:03:32 UTC 2020
New revision: 530631
URL: https://svnweb.freebsd.org/changeset/ports/530631

Log:
  Set a SONAME in libopenblas.so.

  PR:		245320
  Submitted by:	/me
  Approved by:	phd_kimberlite (maintainer)

Changes:
  head/math/openblas/Makefile
  head/math/openblas/files/patch-exports_Makefile