Bug 245346 - New port: mail/mmh CLI mail user agent
Summary: New port: mail/mmh CLI mail user agent
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kurt Jaeger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-04 13:40 UTC by satanist+freebsd
Modified: 2020-05-05 09:17 UTC (History)
2 users (show)

See Also:


Attachments
shar mail/mmh (9.00 KB, text/plain)
2020-04-04 13:40 UTC, satanist+freebsd
no flags Details
shar mail/mmh (8.97 KB, text/plain)
2020-04-04 14:06 UTC, satanist+freebsd
no flags Details
poudriere testport amd64 (195.21 KB, text/plain)
2020-04-04 14:58 UTC, nimaje+fbz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description satanist+freebsd 2020-04-04 13:40:03 UTC
Created attachment 213056 [details]
shar mail/mmh

mmh is a CLI MUA (Mail User Agent). It allows to manage your mail completly from the shell. Fork of mail/nmh, I took the most of the Makefile from this port.
Comment 1 satanist+freebsd 2020-04-04 14:06:21 UTC
Created attachment 213058 [details]
shar mail/mmh

Removed redundant CONFIGURE_ARGS
Comment 2 nimaje+fbz 2020-04-04 14:58:22 UTC
Created attachment 213060 [details]
poudriere testport amd64

QA:
 * testport: OK (poudriere: 12.1-R, amd64/i386, default options tested)
Comment 3 Kurt Jaeger freebsd_committer 2020-05-05 09:16:56 UTC
Committed, thanks!
Comment 4 commit-hook freebsd_committer 2020-05-05 09:17:03 UTC
A commit references this bug:

Author: pi
Date: Tue May  5 09:16:54 UTC 2020
New revision: 534046
URL: https://svnweb.freebsd.org/changeset/ports/534046

Log:
  New port: mail/mmh

  Mmh is a modified version of the electronic mail handling system nmh.
  Nmh (new MH) itself was originally based on the package MH-6.8.3, and
  was intended to be a (mostly) compatible drop-in replacement for MH.
  In contrast, mmh is not intended to be a drop-in replacement for nmh,
  but rather aims for the modernization and simplification of nmh,
  accepting reduced compatiblity if it, at the same time, allows to
  achieve greater goals from mmh's point of view.

  WWW: http://marmaro.de/prog/mmh/

  PR:		245346
  Submitted by:	satanist+freebsd@bureaucracy.de

Changes:
  head/mail/Makefile
  head/mail/mmh/
  head/mail/mmh/Makefile
  head/mail/mmh/distinfo
  head/mail/mmh/files/
  head/mail/mmh/files/patch-man_Makefile.in
  head/mail/mmh/files/patch-uip_Makefile.in
  head/mail/mmh/pkg-descr
  head/mail/mmh/pkg-plist