Bug 245384 - x11/xorgproto - missing keysymbol XF86FullScreen
Summary: x11/xorgproto - missing keysymbol XF86FullScreen
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-05 20:30 UTC by alt2600
Modified: 2020-04-14 19:32 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
screen shot of error message (200.70 KB, image/jpeg)
2020-04-05 20:30 UTC, alt2600
no flags Details
[patch] add XF86XK_FullScreen to xorgproto (1.08 KB, patch)
2020-04-06 15:16 UTC, Niclas Zeising
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description alt2600 2020-04-05 20:30:25 UTC
Created attachment 213106 [details]
screen shot of error message

https://bugs.archlinux.org/task/62449
https://bugs.archlinux.org/task/65730

possibly related to:
https://forums.freebsd.org/threads/new-xorg-switch-from-devd-to-udev.74144/page-3

but not sure the missing symbol may be causing issues, other then is a known missing symbol in:
/usr/local/include/X11/XF86keysym.h

noticed this when I was playing with window managers and forgot to enable one after disabling one in .xinitrc

maybe trivial issue, may not be trivial, I don't know, so I wanted to report. I know xfce seems to have keymap issues with EVDEV changes, but not sure the cause, and took the easy way out by swapping desktops. Not sure if maybe it attempts to compile a keymap and it fails. I know the header says it is no longer being updated by Xorg, so not sure how important it is.
Comment 1 Niclas Zeising freebsd_committer 2020-04-06 06:45:06 UTC
Hi!
I've seen this error too, but as it says, it's not fatal.  This happened after the update to xkeyboard-config and is unrelated to the issues with keyboards and xfce4.  For the xfce4 issue, I suggest looking at pr 196678, which has many suggested tests and fixes for that issue.

I'll look into the missing symbol, it looks like it needs an update to xorgproto.  I need to have a closer look though.
Comment 2 Dmitry Zolotarev 2020-04-06 12:56:09 UTC
Hello.
I got this error too after update xkeyboard-config to 2.29.
I tried to add the symbol to xorgproto and libxkbcommon and recompile them, but it didn't help.
Comment 3 Niclas Zeising freebsd_committer 2020-04-06 12:57:25 UTC
(In reply to Dmitry Zolotarev from comment #2)

I might have a fix, but I haven't yet had time to test it myself, I'll get back with it later today.

I assume that things keep on working as normal, despite the error message?
Comment 4 Dmitry Zolotarev 2020-04-06 13:29:48 UTC
(In reply to Niclas Zeising from comment #3)
No, i3wm freezes.
Comment 5 Dmitry Zolotarev 2020-04-06 13:31:05 UTC
(In reply to Niclas Zeising from comment #3)
If you have a patch I can try to apply and test it.
Comment 6 Dmitry Zolotarev 2020-04-06 14:15:57 UTC
(In reply to Dmitry Zolotarev from comment #4)
Sorry, I think that i3wm working correctly.
But all of my keyboards (Mitsumi KFK-EA4XT and Chicony KU-0420) working incorrectly.
I've run twm and got the same effect: pressed keys doesn't match with displayed symbols.
Before updating xkeyboard-config to 2.29 all working correctly.
Comment 7 Niclas Zeising freebsd_committer 2020-04-06 15:16:53 UTC
Created attachment 213128 [details]
[patch] add XF86XK_FullScreen to xorgproto

Hi!
A new release of xorgproto is forthcoming, but in the meantime I've included the patch that adds XF86XK_FullScreen to xorgproto.  Please apply the patch to your ports tree and rebuild xorgproto.

If it's possible I'd like you to only update xorgproto, and keep everything else as-is. If that doesn't work, please also rebuild xkeyboard-config and report back.

I hope this fix solves your issues.
Comment 8 Dmitry Zolotarev 2020-04-06 15:23:12 UTC
(In reply to Niclas Zeising from comment #7)
Hello. Thanks for your patch.
I've already fix my keyboard changing my keyboard.conf from this:

Section "InputClass"
	Identifier	"KeyboardDefaults"
        Driver "keyboard"
	MatchIsKeyboard	"on"
        Option "XkbModel" "pc104"
	Option "XkbLayout" "us, ru"
	Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle,grp_led:scroll"
EndSection

to this:

Section "InputClass"
	Identifier	"KeyboardDefaults"
	MatchIsKeyboard	"on"
	Option "XkbLayout" "us, ru"
	Option "XkbOptions" "terminate:ctrl_alt_bksp,grp:alt_shift_toggle,grp_led:scroll"
EndSection
Comment 9 Niclas Zeising freebsd_committer 2020-04-06 15:25:58 UTC
(In reply to Dmitry Zolotarev from comment #8)

Ah, OK!
Good to know!
If you have time it would be helpful if you can test the patch as well, to see if the error message goes away.
Thanks!
Comment 10 Dmitry Zolotarev 2020-04-06 15:48:52 UTC
(In reply to Niclas Zeising from comment #9)
Ok, I've applied yout patch to xorgproto and rebuild it and xkeyboard-config.
Then I've run Xorg with my old keyboard config and got the same behavior.
Then I've run Xorg with new keyboard config and all worked fine.
But the error from xkbcomp did not disappear.
Comment 11 Niclas Zeising freebsd_committer 2020-04-06 15:57:30 UTC
(In reply to Dmitry Zolotarev from comment #10)
Yeah, the error message is from somewhere else (seems harmless though).
The change in keyboard behavior is probably from the change from old keyboard rules to evdev rules, and when you updated your config the new config takes that into account.
Thanks for the help in testing!
Comment 12 Dmitry Zolotarev 2020-04-06 16:01:17 UTC
(In reply to Niclas Zeising from comment #11)
It's my pleasure. I'm glad to help my favorite OS :-)
Thanks for your work!
Comment 13 Niclas Zeising freebsd_committer 2020-04-06 16:13:49 UTC
So, after some more digging, to get rid of the error message libX11 needs to be rebuilt as well with the updated xorgproto.  Since this issue is not fatal, I'll wait for the next release of xorgproto, and then commit that together with a libX11 portrevision bump.

Once again thanks for the help!
Comment 14 Dmitry Zolotarev 2020-04-06 16:27:27 UTC
(In reply to Niclas Zeising from comment #13)
Yes, it works fine! Thanks!
Comment 15 commit-hook freebsd_committer 2020-04-14 19:28:23 UTC
A commit references this bug:

Author: zeising
Date: Tue Apr 14 19:27:27 UTC 2020
New revision: 531716
URL: https://svnweb.freebsd.org/changeset/ports/531716

Log:
  x11/xorgproto: Update to 2020.1

  Update x11/xorgproto to 2020.1
  Adds a DPMSNotify event
  Adds XF86XK_FullScreen keysym

  This update is needed to silence the harmless "Could not resolve keysym
  XF86FullScreen" message that can be printed on xorg-server start. [1]

  Complete changelog:
  https://lists.x.org/archives/xorg-announce/2020-April/003042.html

  PR:		245384 [1]
  Reported by:	alt2600@icloud.com  [1]

Changes:
  head/x11/xorgproto/Makefile
  head/x11/xorgproto/distinfo
  head/x11/xorgproto/pkg-plist
Comment 16 commit-hook freebsd_committer 2020-04-14 19:31:25 UTC
A commit references this bug:

Author: zeising
Date: Tue Apr 14 19:31:09 UTC 2020
New revision: 531717
URL: https://svnweb.freebsd.org/changeset/ports/531717

Log:
  x11/libX11: Bump portrevision

  Bump portrevision of x11/libX11 after updating x11/xorgproto in r531716.
  This is needed in order to silence the harmless "Could not resolve keysym
  XF86FullScreen" message that can be printed on xorg-server start.

  PR:		245384
  Reported by:	alt2600@icloud.com

Changes:
  head/x11/libX11/Makefile