Bug 245402 - devel/tigcc: Change BROKEN/DEPRECATED reason
Summary: devel/tigcc: Change BROKEN/DEPRECATED reason
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-06 17:12 UTC by Naram Qashat
Modified: 2020-04-13 08:06 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Naram Qashat 2020-04-06 17:12:55 UTC
So, I noticed that devel/tigcc was marked DEPRECATED because it has been marked BROKEN for more than 6 months, due to its distfiles being unfetchable.

In attempting to resolve this, I found that the snapshot of gcc 4.1 that tigcc requires (20060728) is not available on the GCC mirrors. Despite trying to change the port to use the last 4.1 snapshot (20080630), it will not patch, most likely because of hard references to the old snapshot.

As a result, because of how old the software is and because I don't know if anyone actually uses tigcc under FreeBSD (I don't, I was just trying to keep it maintained just in case), I'd like to change the reason for it being BROKEN and DEPRECATED to say that it is unbuildable on modern systems, or something along those lines.
Comment 1 Alexey Dokuchaev freebsd_committer 2020-04-07 13:08:18 UTC
I happen to have that distfile around, I'll try to unbreak the port instead.
Comment 2 Naram Qashat 2020-04-07 14:15:44 UTC
I have the distfiles too, that isn't the problem. The problem is what I explained in my first message, it will not patch with anything but that one particular gcc snapshot, which doesn't exist on the GCC mirrors anymore and only downloads from the FreeBSD cache. I'm not sure if it is worth the time to chase after this particular version of gcc 4.1.

As for binutils, the version that is on the GNU mirrors is not the same as the one that was originally used in the port (and only the FreeBSD cache has that version up for download). I suspect that binutils 2.16.1 was rerolled at some point after the port's creation.

At this point I don't feel that the port is able to be saved. Either that or drop my maintainership of the port and let someone else take care of it.
Comment 3 Alexey Dokuchaev freebsd_committer 2020-04-07 14:33:32 UTC
(In reply to Naram Qashat from comment #2)
> Either that or drop my maintainership of the port and let someone else
> take care of it.
Ah, OK, as a TI calcs enthusiast, I can take it under my wing for the time being.  It should not be too hard to catch up with more recent GCC/binutils version(s) I hope.
Comment 4 commit-hook freebsd_committer 2020-04-10 15:17:42 UTC
A commit references this bug:

Author: danfe
Date: Fri Apr 10 15:17:23 UTC 2020
New revision: 531324
URL: https://svnweb.freebsd.org/changeset/ports/531324

Log:
  Unbreak, undeprecate, and assume maintainership.

  PR:	245402

Changes:
  head/devel/tigcc/Makefile
Comment 5 Alexey Dokuchaev freebsd_committer 2020-04-13 08:06:39 UTC
ports r531324 should suffice for now.