Bug 245464 - mail/claws-mail: update to latest: 3.17.5
Summary: mail/claws-mail: update to latest: 3.17.5
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords: buildisok, easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2020-04-08 23:52 UTC by Chris Hutchinson
Modified: 2020-04-26 07:49 UTC (History)
2 users (show)

See Also:
portmaster: maintainer-feedback+


Attachments
svn diff for mail/claws-mail: updates to version 3.17.5 (12.94 KB, patch)
2020-04-08 23:52 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2020-04-08 23:52:26 UTC
Created attachment 213202 [details]
svn diff for mail/claws-mail: updates to version 3.17.5

The attached svn diff updates mail/claws-mail to version 3.17.5

New in this release:
~~~~~~~~~~~~~~~~~~~~

* Inline Git patches now have colour syntax highlighting
  The colours of these, and patch attachments, are configurable on
  the 'Other' tab of the Display/Colors page of the general
  preferences.

* The previously hidden preference, 'summary_from_show', is now
  configurable within the UI, on the 'Message List' tab of the
  Display/Summaries page of the general preferences, 'Displayed in
  From column [ ]'.

* 'Re-edit' has been added to the message context menu when in the
  Drafts folder.

* Additional Date header formats are supported:
  - weekday, month, day, hh, mm, ss, year, zone
  - weekday, month, day, hh, mm, ss, year

* LiteHtml viewer plugin: scrolling with the keyboard has been
  implemented.

* The included tools/scripts have been updated:
  o eud2gc.py converted to Python 3
  o tbird2claws.py converted to Python 3
  o tbird2claws.py converted to Python 3
  o google_search.pl has been replaced with ddg_search.pl (that is,
    duckduckgo.com instead of google.com)
  o fix_date.sh and its documentation have been updated 
  o multiwebsearch.pl 'fm' (freshmeat.net) has been removed; 'google'
    has been replaced by 'ddg'
  o the outdated OOo2claws-mail.pl script has been removed

* Updated manuals

* Updated translations: British English, Catalan, Czech, Danish,
  Dutch, French, German, Russian, Slovak, Spanish, Swedish,
  Traditional Chinese, Turkish

* bug fixes:
 many -- not listing in this pr(1)

Tested, and built on FreeBSD 13.0-CURRENT r358902
passes all tests.

That's it!

Thanks!

--Chris
Comment 1 Automation User 2020-04-09 00:19:47 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/134236732
Comment 2 commit-hook freebsd_committer 2020-04-25 11:26:32 UTC
A commit references this bug:

Author: arrowd
Date: Sat Apr 25 11:25:49 UTC 2020
New revision: 532938
URL: https://svnweb.freebsd.org/changeset/ports/532938

Log:
  mail/claws-mail: Update to 3.17.5.

  PR:		245464
  Submitted by:	Chris Hutchinson <portmaster@bsdforge.com>

Changes:
  head/mail/claws-mail/Makefile
  head/mail/claws-mail/Makefile.claws
  head/mail/claws-mail/distinfo
  head/mail/claws-mail/files/patch-configure
  head/mail/claws-mail/files/patch-configure.ac
  head/mail/claws-mail/files/patch-src_plugins_python_accounttype.c
  head/mail/claws-mail/files/patch-src_plugins_python_composewindowtype.c
  head/mail/claws-mail/files/patch-src_plugins_python_folderpropertiestype.c
  head/mail/claws-mail/files/patch-src_plugins_python_foldertype.c
  head/mail/claws-mail/files/patch-src_plugins_python_mailboxtype.c
  head/mail/claws-mail/files/patch-src_plugins_python_messageinfotype.c
  head/mail/claws-mail/pkg-plist
Comment 3 Gleb Popov freebsd_committer 2020-04-25 11:27:49 UTC
Committed, thanks for the patch!
Comment 4 Ivan Rozhuk 2020-04-25 19:44:11 UTC
Can it build and run with python 3.7?
Comment 5 Chris Hutchinson 2020-04-26 04:33:07 UTC
(In reply to rozhuk.im from comment #4)
Likely. I'll test it tomorrow. If it *doesn't*
work. I'll post back.
Otherwise know that it does. :)

--Chris
Comment 6 Chris Hutchinson 2020-04-26 04:57:49 UTC
(In reply to rozhuk.im from comment #4)
YES. I just got a report from a user that indicated
they *only* have python3.7, and removed 3.6
from the USES list in the Makefile, and everything
builds, and works as intended.

I'll update the Makefile, and submit another pr(1)

--Chris
Comment 7 Gleb Popov freebsd_committer 2020-04-26 07:29:24 UTC
Assign newly-created PR to me, so that I quickly commit it.
Comment 8 Chris Hutchinson 2020-04-26 07:49:30 UTC
(In reply to Gleb Popov from comment #7)
Will do.
Thanks Gleb!

--Chris