Bug 245483 - lang/gcc10-devel: fix build on powerpc64 elfv2
Summary: lang/gcc10-devel: fix build on powerpc64 elfv2
Status: Closed DUPLICATE of bug 239266
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: powerpc Any
: --- Affects Only Me
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-09 15:38 UTC by Piotr Kubaj
Modified: 2020-05-03 09:12 UTC (History)
1 user (show)

See Also:
gerald: maintainer-feedback+


Attachments
patch (1.20 KB, patch)
2020-04-09 15:38 UTC, Piotr Kubaj
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Piotr Kubaj freebsd_committer 2020-04-09 15:38:46 UTC
Created attachment 213219 [details]
patch

gcc10-devel needs the same patch that was already commited to other GCC versions.
Comment 1 Gerald Pfeifer freebsd_committer 2020-04-09 20:31:23 UTC
This still should be addressed in clang.

If it's not in time for the GCC 10 release, I will forward port my
hack to gcc10-devel / gcc10.  Right now nothing depends on gcc10-devel
and GCC 10 is WIP.

*** This bug has been marked as a duplicate of bug 239266 ***
Comment 2 commit-hook freebsd_committer 2020-05-03 09:12:08 UTC
A commit references this bug:

Author: gerald
Date: Sun May  3 09:11:13 UTC 2020
New revision: 533759
URL: https://svnweb.freebsd.org/changeset/ports/533759

Log:
  Update to the 20200502 snapshot of GCC 10.0.1, which has branched for
  the release of GCC 10.1 (and the GCC 10 release series) now.

  Forward port r517843 | gerald | 2019-11-17 from lang/gcc9-devel since
  this issue has not been addressed upstream or in our system compiler
  yet. [1]

    clang on rs6000/powerpc* unfortunately poisons user namespace by default
    (without any special options or include files being required).

    Until that changes (or GCC changes) we need to avoid using vec_step as a
    variable name.

  PR:		239266, 245483

Changes:
  head/lang/gcc10-devel/Makefile
  head/lang/gcc10-devel/distinfo
  head/lang/gcc10-devel/patch-clang-vec_step