Bug 245486 - x11-wm/libwraster: update to 0.95.9
Summary: x11-wm/libwraster: update to 0.95.9
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Sato
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-09 17:44 UTC by Marco Beishuizen
Modified: 2020-05-18 22:01 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (hrs)
mbeis: maintainer-feedback?


Attachments
x11-wm/libwraster: update to 0.95.9 (1.73 KB, patch)
2020-04-09 17:44 UTC, Marco Beishuizen
no flags Details | Diff
x11-wm/libwraster: update to 0.95.9 > adding graphics/libexif to libdepends (1.76 KB, patch)
2020-05-01 12:11 UTC, Marco Beishuizen
mbeis: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Beishuizen 2020-04-09 17:44:23 UTC
Created attachment 213225 [details]
x11-wm/libwraster: update to 0.95.9

Update WindowMaker and libwraster to new version 0.95.9.
Comment 1 Rainer Hurling freebsd_committer 2020-05-01 09:35:25 UTC
As far as I can see, there is a missing dependency, the configure script complains about: checking for libexif/exif-data.h.

Adding 'LIB_DEPENDS=libexif.so:graphics/libexif' should solve this issue.
Comment 2 Marco Beishuizen 2020-05-01 12:11:41 UTC
Created attachment 213992 [details]
x11-wm/libwraster: update to 0.95.9 > adding graphics/libexif to libdepends

Adding graphics/libexif to libdepends
Comment 3 mjl 2020-05-18 22:01:42 UTC
I applied this patch, and the one for 245487, and the patches work for me.  It would be good to get these patches integrated, as emacs requires ImageMagick7 and we can't have both ImageMagick6 and ImageMagick7 installed at the same time.