Bug 245847 - editors/abiword 3.0.1_16 fails to build with GRAMMAR=on
Summary: editors/abiword 3.0.1_16 fails to build with GRAMMAR=on
Status: Closed Feedback Timeout
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-23 12:10 UTC by p5B2E9A8F
Modified: 2020-08-08 14:24 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (gnome)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description p5B2E9A8F 2020-04-23 12:10:11 UTC
libtool: compile:  c++ -DHAVE_CONFIG_H -I. -I../../.. -I/usr/local/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include -pthread -I/usr/local/include/libpng16 -I/usr/local/include/fribidi -I/usr/local/include -I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include -I/usr/local/include/libgsf-1 -I/usr/local/include/libxml2 -I/usr/local/include/wv -I/usr/local/include/freetype2 -I/usr/local/include/enchant -I/usr/local/include/libgoffice-0.10 -I/usr/local/include/gtk-3.0 -I/usr/local/include/pango-1.0 -I/usr/local/include/cairo -I/usr/local/include/pixman-1 -I/usr/local/include/libpng16 -I/usr/local/include/harfbuzz -I/usr/local/include/gdk-pixbuf-2.0 -I/usr/local/include/gio-unix-2.0/ -I/usr/local/include/libdrm -I/usr/local/include/atk-1.0 -I/usr/local/include/at-spi2-atk/2.0 -I/usr/local/include/at-spi-2.0 -I/usr/local/include/dbus-1.0 -I/usr/local/lib/dbus-1.0/include -I/usr/local/include/librsvg-2.0 -I/usr/local/include/gtk-3.0/unix-print -D_THREAD_SAFE -pthread -I/usr/local/include -I../../.. -I../../../src/af/ev/gtk -I../../../src/af/ev/xp -I../../../src/af/gr/gtk -I../../../src/af/gr/xp -I../../../src/af/util/unix -I../../../src/af/util/xp -I../../../src/af/xap/gtk -I../../../src/af/xap/xp -I../../../src/text/fmt/gtk -I../../../src/text/fmt/xp -I../../../src/text/ptbl/xp -I../../../src/wp/impexp/gtk -I../../../src/wp/impexp/xp -I../../../src/wp/ap/gtk -I../../../src/wp/ap/xp -I../../../src/plugins -DABI_DLL -DABI_BUILD_VERSION=\"3.0.1\" -I/usr/local/include -DLIBICONV_PLUG -Wall -Wextra -Wsign-compare -Wpointer-arith -Wchar-subscripts -Wwrite-strings -Wmissing-noreturn -Wunused -Wpointer-arith -Wshadow -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wno-overloaded-virtual -MT LinkGrammarWrap.lo -MD -MP -MF .deps/LinkGrammarWrap.Tpo -c LinkGrammarWrap.cpp  -fPIC -DPIC -o .libs/LinkGrammarWrap.o
LinkGrammarWrap.cpp:90:3: error: use of undeclared identifier 'parse_options_set_panic_mode'; did you mean 'parse_options_set_max_memory'?
  parse_options_set_panic_mode(m_Opts, TRUE);
  ^~~~~~~~~~~~~~~~~~~~~~~~~~~~
  parse_options_set_max_memory
/usr/local/include/link-grammar/link-includes.h:177:6: note: 'parse_options_set_max_memory' declared here
     parse_options_set_max_memory(Parse_Options  opts, int mem);
     ^
LinkGrammarWrap.cpp:148:41: error: use of undeclared identifier 'sentence_get_nth_word'
          pWordMap->m_iErrHigh = iLow + strlen(sentence_get_nth_word(sent, i));
                                               ^
LinkGrammarWrap.cpp:152:8: error: use of undeclared identifier 'sentence_nth_word_has_disjunction'
          if(!sentence_nth_word_has_disjunction(sent, i))
              ^
LinkGrammarWrap.cpp:170:30: error: use of undeclared identifier 'sentence_get_nth_word'
              iHigh = iLow + strlen(sentence_get_nth_word(sent, i));
                                    ^
LinkGrammarWrap.cpp:191:30: error: use of undeclared identifier 'sentence_get_nth_word'
              iHigh = iLow + strlen(sentence_get_nth_word(sent, i)) + iOff;
                                    ^
LinkGrammarWrap.cpp:200:19: error: use of undeclared identifier 'sentence_get_nth_word'
          iLow += strlen(sentence_get_nth_word(sent, i));
                         ^
LinkGrammarWrap.cpp:232:20: error: use of undeclared identifier 'linkage_get_num_sublinkages'; did you mean 'linkage_get_num_links'?
        UT_sint32 count = linkage_get_num_sublinkages(linkage);
                          ^~~~~~~~~~~~~~~~~~~~~~~~~~~
                          linkage_get_num_links
/usr/local/include/link-grammar/link-includes.h:296:6: note: 'linkage_get_num_links' declared here
     linkage_get_num_links(const Linkage linkage);
     ^
LinkGrammarWrap.cpp:238:20: error: use of undeclared identifier 'linkage_set_current_sublinkage'
          UT_sint32 iok = linkage_set_current_sublinkage(linkage, i);
                          ^
8 errors generated.
gmake[5]: *** [Makefile:569: LinkGrammarWrap.lo] Error 1
gmake[5]: Leaving directory '/wrkdirs/usr/ports/editors/abiword/work/abiword-3.0.1/plugins/grammar/linkgrammarwrap'
gmake[4]: *** [Makefile:678: all-recursive] Error 1
gmake[4]: Leaving directory '/wrkdirs/usr/ports/editors/abiword/work/abiword-3.0.1/plugins/grammar'
gmake[3]: *** [Makefile:528: all-recursive] Error 1
gmake[3]: Leaving directory '/wrkdirs/usr/ports/editors/abiword/work/abiword-3.0.1/plugins'
gmake[2]: *** [Makefile:774: all-recursive] Error 1
gmake[2]: Leaving directory '/wrkdirs/usr/ports/editors/abiword/work/abiword-3.0.1'
gmake[1]: *** [Makefile:593: all] Error 2
gmake[1]: Leaving directory '/wrkdirs/usr/ports/editors/abiword/work/abiword-3.0.1'
===> Compilation failed unexpectedly.
Try to set MAKE_JOBS_UNSAFE=yes and rebuild before reporting the failure to
the maintainer.
*** Error code 1

Stop.
make: stopped in /usr/ports/editors/abiword
=>> Cleaning up wrkdir
===>  Cleaning for abiword-3.0.1_16
build of editors/abiword | abiword-3.0.1_16 ended at Thu Apr 23 12:57:28 CEST 2020
build time: 00:03:28
!!! build failure encountered !!!
Comment 1 p5B2E9A8F 2020-08-08 14:24:10 UTC
I do not care either anymore.