Bug 245922 - [PATCH] www/otter-browser: missing LIB_DEPENDS for QTWEBENGINE option
Summary: [PATCH] www/otter-browser: missing LIB_DEPENDS for QTWEBENGINE option
Status: Closed Works As Intended
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-kde (Team)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-26 10:44 UTC by Andy Mender
Modified: 2020-04-27 16:46 UTC (History)
1 user (show)

See Also:
tcberner: maintainer-feedback+


Attachments
Makefile diff (495 bytes, patch)
2020-04-26 10:44 UTC, Andy Mender
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Mender 2020-04-26 10:44:33 UTC
Created attachment 213799 [details]
Makefile diff

QTWEBENGINE requires libdouble-conversion.so.3, but it's not declared as a build dependency. This shared object is provided by the devel/double-conversion port. The attached Makefile diff fixes the issue.
Comment 1 Tobias C. Berner freebsd_committer 2020-04-26 13:45:15 UTC
Moin moin 

Thanks for the report. However, I am unable to find any reference to libdouble-conversion in otter's cmake.

How did you conclude it's a requirement?  


mfg Tobias
Comment 2 Andy Mender 2020-04-26 15:42:57 UTC
(In reply to Tobias C. Berner from comment #1)
The build process for the QtWebEngine version of Otter fails when trying to use definitions from libdouble-conversion. Installing the devel/double-conversion port provides the shared object I mentioned and allows the build to conclude successfully.

However, now I realized that it might actually be the www/qt5-webengine port that's affected, not the www/otter-browser port. I am checking this now.
Comment 3 Andy Mender 2020-04-26 19:32:56 UTC
Apologies for the erroneous submission. Indeed, the problem was related to the www/qt5-webengine port. The correctly submitted report is available as bug #245946.

I am closing this submission.
Comment 4 Tobias C. Berner freebsd_committer 2020-04-27 16:46:35 UTC
No worries.