Bug 245933 - multimedia/gpac-mp4box: update to 0.8.0, remove DEPRECATED
Summary: multimedia/gpac-mp4box: update to 0.8.0, remove DEPRECATED
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords: needs-qa, patch
Depends on: 245932
Blocks:
  Show dependency treegraph
 
Reported: 2020-04-26 14:51 UTC by Stefan Ehmann
Modified: 2020-08-01 07:31 UTC (History)
4 users (show)

See Also:
riggs: maintainer-feedback-
riggs: merge-quarterly+


Attachments
patch to update gpac-mp4box to 0.8.0 (1.32 KB, patch)
2020-04-26 14:51 UTC, Stefan Ehmann
no flags Details | Diff
patch to update gpac-mp4box to 1.0.0 (1.60 KB, patch)
2020-07-19 09:02 UTC, Stefan Ehmann
no flags Details | Diff
last patch with portlint fixes (1.60 KB, patch)
2020-07-19 12:09 UTC, Rene Ladan
no flags Details | Diff
added USES=localbase (1.64 KB, patch)
2020-07-19 12:27 UTC, Rene Ladan
rene: maintainer-approval?
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Ehmann 2020-04-26 14:51:20 UTC
Created attachment 213811 [details]
patch to update gpac-mp4box to 0.8.0

Port is scheduled for removal on 2020-05-05.

Update to to 0.8.0 and remove DEPRECATED.
Also switch to USE_GITHUB.

Depends on update of multimedia/gpac-libgpac (Bug 245932), build fails with outdated libgpac currently in ports.
Comment 1 Stefan Ehmann 2020-07-19 09:02:37 UTC
Created attachment 216566 [details]
patch to update gpac-mp4box to 1.0.0

Add new patch for version 1.0.0
Comment 2 Rene Ladan freebsd_committer 2020-07-19 12:07:21 UTC
The patch builds fine on 11.3-i386, 12.1-amd64 and a few weeks old CURRENT. I did fix a few portlint errors (reordering some variables and fixing whitespace).

@pvizeli can you approve the patch?
Comment 3 Rene Ladan freebsd_committer 2020-07-19 12:09:18 UTC
Created attachment 216569 [details]
last patch with portlint fixes
Comment 4 Rene Ladan freebsd_committer 2020-07-19 12:26:15 UTC
Now with USES=localbase to tidy things up.
Comment 5 Rene Ladan freebsd_committer 2020-07-19 12:27:12 UTC
Created attachment 216572 [details]
added USES=localbase
Comment 6 Thomas Zander freebsd_committer 2020-07-19 13:36:58 UTC
(In reply to Rene Ladan from comment #5)

Give me a heads-up when this is ready for commit to HEAD.
We can then MFH multimedia/gpac-* updates and x264 compatibility patch from r542565, so the quarterly branch gets those goodies too.
Comment 7 Stefan Ehmann 2020-07-19 17:22:28 UTC
There is an issue with the new version:

$ mp4box 
[Core] default modules not found
[core] Cannot create config file GPAC.cfg in /home/stefan/.gpac directory
Fatal error: failed to initialize GPAC global configuration

I use the following workaround
$ touch ~/.gpac/profiles/0/GPAC.cfg/.gpac/modules/gm_

Seems to be an issue with multimedia/gpac-libgpac. There is an upstream bug report that looks very similiar but the patch didn't work for me:
https://github.com/gpac/gpac/issues/1540
Comment 8 Stefan Ehmann 2020-07-25 20:52:42 UTC
Actually, the issue is that we don't build/install modules.

Adding "--static-modules" to CONFIGURE_ARGS of multimedia/gpac-libgpac fixes this issue.

Alternatively, installing the modules should also fix it (but haven't tried that).
Comment 9 Rene Ladan freebsd_committer 2020-07-28 17:24:15 UTC
(In reply to Stefan Ehmann from comment #8)
Thomas, any thoughts on this? Feel free to take over this PR if you feel like it ;)
Comment 10 Thomas Zander freebsd_committer 2020-07-29 22:33:23 UTC
(In reply to Rene Ladan from comment #9)

Sure, I can take a look over the next few days. The maintainer is MIA it seems?!
Comment 11 commit-hook freebsd_committer 2020-08-01 07:22:36 UTC
A commit references this bug:

Author: riggs
Date: Sat Aug  1 07:21:52 UTC 2020
New revision: 543892
URL: https://svnweb.freebsd.org/changeset/ports/543892

Log:
  Enable static modules (preparation for build fix of multimedia/gpac-mp4box)

  PR:		245933
  Reported by:	shoesoft@gmx.net
  Reviewed by:	rene, riggs
  MFH:		2020Q3 (build fix blanket)

Changes:
  head/multimedia/gpac-libgpac/Makefile
Comment 12 Thomas Zander freebsd_committer 2020-08-01 07:23:25 UTC
Maintainer timeout
Comment 13 commit-hook freebsd_committer 2020-08-01 07:24:39 UTC
A commit references this bug:

Author: riggs
Date: Sat Aug  1 07:23:40 UTC 2020
New revision: 543893
URL: https://svnweb.freebsd.org/changeset/ports/543893

Log:
  Un-break build, update to 1.0.0, switch to GitHub repository.

  PR:		245933
  Submitted by:	shoesoft@gmx.net
  Reviewed by:	rene, riggs
  Approved by:	maintainer timeout
  MFH:		2020Q3 (build fix blanket)

Changes:
  head/multimedia/gpac-mp4box/Makefile
  head/multimedia/gpac-mp4box/distinfo
Comment 14 commit-hook freebsd_committer 2020-08-01 07:27:42 UTC
A commit references this bug:

Author: riggs
Date: Sat Aug  1 07:27:06 UTC 2020
New revision: 543894
URL: https://svnweb.freebsd.org/changeset/ports/543894

Log:
  MFH: r542531 r543892 r543893

  Update to upstream version 1.0.0

  PR:		245932
  Submitted by:	shoesoft@gmx.net
  Reviewed by:	riggs

  Enable static modules (preparation for build fix of multimedia/gpac-mp4box)

  PR:		245933
  Reported by:	shoesoft@gmx.net
  Reviewed by:	rene, riggs

  Un-break build, update to 1.0.0, switch to GitHub repository.

  PR:		245933
  Submitted by:	shoesoft@gmx.net
  Reviewed by:	rene, riggs
  Approved by:	maintainer timeout

  Approved by:	ports-secteam (build fix blanket)

Changes:
_U  branches/2020Q3/
  branches/2020Q3/multimedia/gpac-libgpac/Makefile
  branches/2020Q3/multimedia/gpac-libgpac/distinfo
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-export-x264-symbols
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-src-utils-os_config_init.c
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-src-utils-os_divers.c
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-src_quickjs_quickjs.c
  branches/2020Q3/multimedia/gpac-libgpac/pkg-plist
  branches/2020Q3/multimedia/gpac-mp4box/Makefile
  branches/2020Q3/multimedia/gpac-mp4box/distinfo
Comment 15 commit-hook freebsd_committer 2020-08-01 07:27:44 UTC
A commit references this bug:

Author: riggs
Date: Sat Aug  1 07:27:07 UTC 2020
New revision: 543894
URL: https://svnweb.freebsd.org/changeset/ports/543894

Log:
  MFH: r542531 r543892 r543893

  Update to upstream version 1.0.0

  PR:		245932
  Submitted by:	shoesoft@gmx.net
  Reviewed by:	riggs

  Enable static modules (preparation for build fix of multimedia/gpac-mp4box)

  PR:		245933
  Reported by:	shoesoft@gmx.net
  Reviewed by:	rene, riggs

  Un-break build, update to 1.0.0, switch to GitHub repository.

  PR:		245933
  Submitted by:	shoesoft@gmx.net
  Reviewed by:	rene, riggs
  Approved by:	maintainer timeout

  Approved by:	ports-secteam (build fix blanket)

Changes:
_U  branches/2020Q3/
  branches/2020Q3/multimedia/gpac-libgpac/Makefile
  branches/2020Q3/multimedia/gpac-libgpac/distinfo
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-export-x264-symbols
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-src-utils-os_config_init.c
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-src-utils-os_divers.c
  branches/2020Q3/multimedia/gpac-libgpac/files/patch-src_quickjs_quickjs.c
  branches/2020Q3/multimedia/gpac-libgpac/pkg-plist
  branches/2020Q3/multimedia/gpac-mp4box/Makefile
  branches/2020Q3/multimedia/gpac-mp4box/distinfo