Bug 245939 - mail/claws-mail: reorganize plugins
Summary: mail/claws-mail: reorganize plugins
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Andree
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-26 16:32 UTC by rozhuk.im
Modified: 2020-06-11 18:37 UTC (History)
4 users (show)

See Also:
portmaster: maintainer-feedback+


Attachments
patch (19.29 KB, patch)
2020-04-26 16:32 UTC, rozhuk.im
no flags Details | Diff
svn diff to create mets-port for claws-mail-plugins (19.34 KB, patch)
2020-05-10 23:16 UTC, Chris Hutchinson
portmaster: maintainer-approval+
Details | Diff
QA log against the most recent patch attached to this pr (12.32 KB, text/plain)
2020-05-10 23:17 UTC, Chris Hutchinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description rozhuk.im 2020-04-26 16:32:57 UTC
Created attachment 213816 [details]
patch

Rename:
mail/claws-mail-archiver -> mail/claws-mail-archive
mail/claws-mail-attach_warner -> mail/claws-mail-attachwarner
mail/claws-mail-spamreport -> mail/claws-mail-spam_report
mail/claws-mail-tnef -> mail/claws-mail-tnef_parse

Now all ports name equals internal plugins names.


Add:
mail/claws-mail-dillo: Viewing of html messages using the Dillo web browser
mail/claws-mail-litehtml_viewer: Viewer plugin for HTML emails, using the litehtml library
mail/claws-mail-plugins: claws-mail plugins meta-port


Move CLAWS_PLUGINS from claws-mail/Makefile.claws to new file: claws-mail/Makefile.claws.plugins
Comment 1 Chris Hutchinson 2020-04-26 23:21:32 UTC
Comment on attachment 213816 [details]
patch

I love it. Thank you for all the time, and effort you
put into this!

Approved. :)

--Chris
Comment 2 rozhuk.im 2020-04-27 02:09:52 UTC
(In reply to Chris Hutchinson from comment #1)

You are welcome :)

There is few issues with clams-mail for me that I fail to fix:
- plugins build with -j1 - no idea where and why this hardcoded
- notify icon + xfce4 compositor = freezes all windows on claws restores from tray icon. Same freezes happen then in "window manager tweaks" -> "Compositor" toggle "Show shadows"*** switches. Looks like this is more xfce4 bug, but all other apps works ok.
Comment 3 Chris Hutchinson 2020-04-27 03:27:49 UTC
(In reply to rozhuk.im from comment #2)

> There is few issues with clams-mail for me that I fail to fix:
> - plugins build with -j1 - no idea where and why this hardcoded
Thanks for mentioning that. I'll have a look, and patch that restriction
out.

> - notify icon + xfce4 compositor = freezes all windows on claws restores from > tray icon.
Hmm, don't see this on my copy on xfce4 && 13-CURRENT.
Driver related?
I'll look into it, just the same. :)

Thanks again!

--Chris
Comment 4 Chris Hutchinson 2020-05-10 23:16:29 UTC
Created attachment 214366 [details]
svn diff to create mets-port for claws-mail-plugins

This patch obsoletes the original patch attached to this pr.
This patch simply adds MAINTAINER to the original. This
patch has been tested against 13/amd64. It applies, and
completes a build install as intended (QA log also attached).

That's it.

Thanks!

--Chris
Comment 5 Chris Hutchinson 2020-05-10 23:17:54 UTC
Created attachment 214367 [details]
QA log against the most recent patch attached to this pr

QA log against the patch I just attached to this pr.
Comment 6 Chris Hutchinson 2020-05-19 17:55:31 UTC
Please? :-)
Comment 7 Chris Hutchinson 2020-06-10 22:13:59 UTC
Can I please get a commit?
I have more stuff in the pipeline for Claws. But
must wait for this to clear first.

Thank you.

--Chris
Comment 8 Fernando Apesteguía freebsd_committer 2020-06-11 05:42:47 UTC
^Triage: [tags] in issue Titles are deprecated
Comment 9 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-11 13:25:52 UTC
Comment on attachment 213816 [details]
patch

^Triage: Obsolete older patch (less confusing)
Comment 10 commit-hook freebsd_committer 2020-06-11 17:50:13 UTC
A commit references this bug:

Author: mandree
Date: Thu Jun 11 17:50:05 UTC 2020
New revision: 538519
URL: https://svnweb.freebsd.org/changeset/ports/538519

Log:
  mail/claws-mail: reorganize plugins

  renames a few ports to match their names to the plugin names
  (adding to MOVED)

  PR:		245939
  PR:		239659
  Submitted by:	rozhuk.im@gmail.com
  Approved by:	Chris Hutchinson <portmaster@bsdforge.com> (maintainer)

Changes:
  head/MOVED
  head/mail/Makefile
  head/mail/claws-mail/Makefile.claws
  head/mail/claws-mail/Makefile.claws.plugins
  head/mail/claws-mail-address_keeper/Makefile
  head/mail/claws-mail-archive/
  head/mail/claws-mail-archive/Makefile
  head/mail/claws-mail-archiver/
  head/mail/claws-mail-att_remover/Makefile
  head/mail/claws-mail-attach_warner/
  head/mail/claws-mail-attachwarner/
  head/mail/claws-mail-attachwarner/Makefile
  head/mail/claws-mail-bogofilter/Makefile
  head/mail/claws-mail-bsfilter/Makefile
  head/mail/claws-mail-clamd/Makefile
  head/mail/claws-mail-dillo/
  head/mail/claws-mail-dillo/Makefile
  head/mail/claws-mail-dillo/pkg-descr
  head/mail/claws-mail-fetchinfo/Makefile
  head/mail/claws-mail-gdata/Makefile
  head/mail/claws-mail-libravatar/Makefile
  head/mail/claws-mail-litehtml_viewer/
  head/mail/claws-mail-litehtml_viewer/Makefile
  head/mail/claws-mail-litehtml_viewer/pkg-descr
  head/mail/claws-mail-mailmbox/Makefile
  head/mail/claws-mail-managesieve/Makefile
  head/mail/claws-mail-newmail/Makefile
  head/mail/claws-mail-notification/Makefile
  head/mail/claws-mail-pdf_viewer/Makefile
  head/mail/claws-mail-perl/Makefile
  head/mail/claws-mail-plugins/
  head/mail/claws-mail-plugins/Makefile
  head/mail/claws-mail-plugins/pkg-descr
  head/mail/claws-mail-rssyl/Makefile
  head/mail/claws-mail-spam_report/
  head/mail/claws-mail-spam_report/Makefile
  head/mail/claws-mail-spamassassin/Makefile
  head/mail/claws-mail-spamreport/
  head/mail/claws-mail-tnef/
  head/mail/claws-mail-tnef_parse/
  head/mail/claws-mail-tnef_parse/Makefile
  head/mail/claws-mail-vcalendar/Makefile
Comment 11 Matthias Andree freebsd_committer 2020-06-11 17:51:27 UTC
next time, please include updates to MOVED and mail/Makefile. Thank you.
Comment 12 Chris Hutchinson 2020-06-11 18:37:01 UTC
(In reply to Matthias Andree from comment #11)
Will do.
Thanks! :-)

--Chris