Bug 245989 - www/wt: Update to 4.3.1
Summary: www/wt: Update to 4.3.1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Loïc Bartoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-28 05:05 UTC by Mohammad S. Babaei
Modified: 2020-05-02 06:36 UTC (History)
1 user (show)

See Also:


Attachments
www/wt v4.3.0 to v4.3.1 patch file (2.09 KB, patch)
2020-04-28 05:05 UTC, Mohammad S. Babaei
info: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mohammad S. Babaei 2020-04-28 05:05:31 UTC
Created attachment 213877 [details]
www/wt v4.3.0 to v4.3.1 patch file

Release 4.3.1 (April 20, 2020)

This release fixes the following issues:

    WWebWidget: moved id_ out of OtherImpl: this fixes issues caused by the id_ being removed before other things that depend on it, like the jsScrollVisibilityChanged_ signal. Fixes issue #7508.
    Fixed join information not being copied over when copying Wt::Dbo::AbstractQuery.
    MinGW fixes: Direct2D/DirectWrite were disabled and are now enabled by default. Libraries were changed to lowercase for cross-compiling from Linux. Windows is case-insensitive, and MinGW libraries on Linux are lowercase. Fixes issue #7505.
    Fixed a wrong documentation link in the widget gallery.

https://www.webtoolkit.eu/wt/doc/reference/html/Releasenotes.html
Comment 1 commit-hook freebsd_committer 2020-05-02 06:35:34 UTC
A commit references this bug:

Author: lbartoletti
Date: Sat May  2 06:35:01 UTC 2020
New revision: 533666
URL: https://svnweb.freebsd.org/changeset/ports/533666

Log:
  www/wt: Update to 4.3.1

  Changelog:
    - https://www.webtoolkit.eu/wt/doc/reference/html/Releasenotes.html

  PR:		245989
  Submitted by:	 Mohammad S. Babaei (maintainer)
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D24633

Changes:
  head/www/wt/Makefile
  head/www/wt/distinfo
  head/www/wt/pkg-plist
Comment 2 Loïc Bartoletti freebsd_committer 2020-05-02 06:36:09 UTC
Committed, thanks!