Bug 246036 - www/node still depends on lang/python27, which is deprecated
Summary: www/node still depends on lang/python27, which is deprecated
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Bradley T. Hughes
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-29 22:55 UTC by lumiwa
Modified: 2020-09-15 15:50 UTC (History)
2 users (show)

See Also:
bhughes: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description lumiwa 2020-04-29 22:55:14 UTC
Port www/node has
Build dependencies:

        c-ares>=1.15.0 : dns/c-ares
        libuv>=1.35.0 : devel/libuv
        libnghttp2>=1.40.0 : www/libnghttp2
        icu>=64.2 : devel/icu  
        gmake : devel/gmake
        python2.7 : lang/python27
        pkgconf>=1.3.0_1 : devel/pkgconf  

and Python 2/7 is deprecated.

Thank you.
Comment 1 lumiwa 2020-04-29 22:55:32 UTC
Port www/node has
Build dependencies:

        c-ares>=1.15.0 : dns/c-ares
        libuv>=1.35.0 : devel/libuv
        libnghttp2>=1.40.0 : www/libnghttp2
        icu>=64.2 : devel/icu  
        gmake : devel/gmake
        python2.7 : lang/python27
        pkgconf>=1.3.0_1 : devel/pkgconf  

and Python 2/7 is deprecated.

Thank you.
Comment 2 Bradley T. Hughes freebsd_committer 2020-05-05 21:33:12 UTC
Yes, I am aware of this and am working on making www/node build with the default version of python pulled in by USES+=python:build.
Comment 3 commit-hook freebsd_committer 2020-05-15 20:33:27 UTC
A commit references this bug:

Author: bhughes
Date: Fri May 15 20:33:02 UTC 2020
New revision: 535334
URL: https://svnweb.freebsd.org/changeset/ports/535334

Log:
  www/node: use python 3 as build dependency

  Do not depend on the deprecated python 2.7 package to build Node.js,
  patching tools/genv8constants.py to continue to work and generate the
  same output with python 3 that it did with python 2.

  While here, add all *.py scripts used by the build to SHEBANG_FILES,
  which causes the installed lldb_commands.py script to change, hence the
  PORTREVISION bump.

  PR:		246036
  Reported by:	lumiwa@gmail.com
  Sponsored by:	Miles AS

Changes:
  head/www/node/Makefile
  head/www/node/files/patch-tools_genv8constants.py
Comment 4 Bradley T. Hughes freebsd_committer 2020-05-15 20:34:17 UTC
Fixed, thanks for the report :)