Bug 246062 - sysutils/burp: burp-2.2.18 overwrites configfiles with each install
Summary: sysutils/burp: burp-2.2.18 overwrites configfiles with each install
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Lorenzo Salvadore
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-04-30 16:29 UTC by Benedikt Hochstrasser
Modified: 2020-05-04 19:23 UTC (History)
0 users

See Also:
salvadore: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Benedikt Hochstrasser 2020-04-30 16:29:54 UTC
install burp-2.2.18 via package ("pkg install burp"). Edit /usr/local/etc/burp/burp*.conf to suit your needs.
Reinstalling or updating burp will overwrite usr/local/etc/burp*.conf with defaults, without warning, without creating backups.

Expected behaviour: package installs only burp.conf.sample and burp-server.conf.sample and leaves burp.conf and burp-server.conf as is.

Workaround: save .conf files before updating, or reference own .conf files in /etc/rc.conf and crontab jobs.

Best, Ben
Comment 1 Lorenzo Salvadore freebsd_committer 2020-04-30 16:53:56 UTC
(In reply to Benedikt Hochstrasser from comment #0)

Thanks for reporting! I will fix it as soon as possible.
Comment 2 Lorenzo Salvadore freebsd_committer 2020-05-01 12:59:03 UTC
I could not reproduce your issue.

The problem was indeed present before, but it should have been fixed with https://svnweb.freebsd.org/ports?view=revision&revision=530237 i.e. since 2.2.18_3.

Is it possible that you were updating from a version earlier than 2.2.18_3 to version 2.2.18_3 or 2.2.18_4? Can you please repeat your test removing and installing burp-2.2.18_3 or burp-2.2.18_4? Or updating from 2.2.18_3 to 2.2.18_4? Whichever is easier for you is fine.
Comment 3 Benedikt Hochstrasser 2020-05-02 14:47:21 UTC
(In reply to Lorenzo Salvadore from comment #2)
Hi Lorenzo,
2.2.18_4 (off the 'latest' branch) is fine. Thing is, my system by default went to 'quarterly' where we're still on 2.2.18_2.

So everything is ok. You may close the case.
Comment 4 commit-hook freebsd_committer 2020-05-04 19:22:31 UTC
A commit references this bug:

Author: salvadore
Date: Mon May  4 19:21:56 UTC 2020
New revision: 533970
URL: https://svnweb.freebsd.org/changeset/ports/533970

Log:
  MFH: r530237

  sysutils/burp-devel: Update to 2.3.24

  - Protocol 2: warn and skip on verify/restore of unsupported file types.
  - Resurrect, improve and use sysutils/burp/files/burp.in instead of the rc
  script from distfile, both for sysutils/burp (master port) and for
  sysutils/burp-devel (slave port): this is necessary because, while
  sysutils/burp's distfile still distributes the script, sysutils/burp-devel's
  distfile does not anymore starting with version 2.3.24. I also made a few
  modifications to the file so that it behaves well with non standard PREFIX
  values.
  - Fix bug #246062.

  Reviewed by:	0mp, gerald, dbaio, adamw
  Approved by:	tcberner (co-mentor)
  Differential Revision:	https://reviews.freebsd.org/D24104

  PR:	246062
  Reported by:	tictactux@gmail.com
  Approved by:	ports-secteam (joneum), gerald (mentor)

Changes:
_U  branches/2020Q2/
  branches/2020Q2/sysutils/burp/Makefile
  branches/2020Q2/sysutils/burp/files/
  branches/2020Q2/sysutils/burp/pkg-plist
  branches/2020Q2/sysutils/burp-devel/Makefile
  branches/2020Q2/sysutils/burp-devel/distinfo
Comment 5 Lorenzo Salvadore freebsd_committer 2020-05-04 19:23:58 UTC
It is now fixed in the quarterly branch as well.

Thanks for reporting!