Bug 246067 - games/libretro-*: Update libretro and fix path
Summary: games/libretro-*: Update libretro and fix path
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Loïc Bartoletti
URL:
Keywords:
: 246134 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-04-30 20:04 UTC by Daniel Menelkir
Modified: 2020-05-16 06:07 UTC (History)
4 users (show)

See Also:
menelkir: maintainer-feedback+


Attachments
libretro-cores.diff (34.80 KB, patch)
2020-04-30 20:04 UTC, Daniel Menelkir
menelkir: maintainer-approval+
Details | Diff
libretro-cores-v2.diff (34.70 KB, patch)
2020-05-01 13:13 UTC, Daniel Menelkir
no flags Details | Diff
libretro-cores-v3.diff (42.40 KB, patch)
2020-05-04 08:44 UTC, Daniel Menelkir
no flags Details | Diff
libretro-cores-v4.diff (74.84 KB, patch)
2020-05-05 22:57 UTC, Daniel Menelkir
no flags Details | Diff
libretro-cores-v5.diff (74.29 KB, patch)
2020-05-08 06:58 UTC, Daniel Menelkir
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Menelkir 2020-04-30 20:04:00 UTC
Created attachment 213963 [details]
libretro-cores.diff

Changelog:

Suggested by Greg: All libretro-cores now should reside in /usr/local/lib/libretro instead of /usr/local/libexec/libretro so libretro compatible emulators should work out of the box.
URL: https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246028#c3

Suggested by Rozhuk: Fix for beetle-bsnes-libretro
URL: https://github.com/libretro/beetle-bsnes-libretro/issues/42
Comment 1 Tobias C. Berner freebsd_committer 2020-05-01 07:45:49 UTC
Moin moin

Please create a static patch in files/ for this change:
post-patch:
	@${REINPLACE_CMD} -e 's|free(temp)|delete temp|g' \
	${WRKSRC}/mednafen/mednafen.cpp


mfg Tobias
Comment 2 Daniel Menelkir 2020-05-01 13:13:15 UTC
Created attachment 213996 [details]
libretro-cores-v2.diff

Done.
Comment 3 sdalu 2020-05-03 17:28:57 UTC
*** Bug 246134 has been marked as a duplicate of this bug. ***
Comment 4 Daniel Menelkir 2020-05-04 07:24:04 UTC
I'll bump the version number to the current date, for the sake of reference in a matter of update. I'll update asap.
Comment 5 Daniel Menelkir 2020-05-04 08:44:08 UTC
Created attachment 214096 [details]
libretro-cores-v3.diff

Fixed the PORTVERSION. Now is ready to go.
Comment 6 Loïc Bartoletti freebsd_committer 2020-05-05 07:33:59 UTC
Hi Daniel,

Can you also change the logic of the do-install (request: https://reviews.freebsd.org/D24516#inline-152772)

(you replace the find with the path to the library.)
Comment 7 Daniel Menelkir 2020-05-05 07:58:24 UTC
(In reply to Loïc Bartoletti from comment #6)

I don't know what is the best practice for that. Since name convention and resulting library is quite confusing in libretro cores world. Should I mention, for example, /path/name_libretro.so directly inside the Makefile?
Comment 8 Daniel Menelkir 2020-05-05 22:57:42 UTC
Created attachment 214177 [details]
libretro-cores-v4.diff

* Forgot to redo the checksums, done.
* Modified the do-install per core, because some cores are in different places at the end of the build.
Comment 9 Daniel Menelkir 2020-05-08 06:58:33 UTC
Created attachment 214262 [details]
libretro-cores-v5.diff

Removed ${COREDIR} variable.
Comment 10 Loïc Bartoletti freebsd_committer 2020-05-12 13:27:18 UTC
If I'm not wrong the files/patch is missing for beetle-bsnes-libretro
Comment 11 Daniel Menelkir 2020-05-12 22:51:19 UTC
(In reply to Loïc Bartoletti from comment #10)

It was already commited to upstream and I didn't modified the patches.
Comment 12 commit-hook freebsd_committer 2020-05-16 06:04:57 UTC
A commit references this bug:

Author: lbartoletti
Date: Sat May 16 06:03:53 UTC 2020
New revision: 535353
URL: https://svnweb.freebsd.org/changeset/ports/535353

Log:
  games/libretro-*: Update libretro cores and fix path

  Update cores and fix path.
  Some users complain than cores are installed in libexec instead of lib where RetroArch looks. So emulators will work out of box.

  PR:	246067
  Submitted by:	menelkir@itroll.org (maintainer)
  Approved by:	tcberner (mentor)
  Differential Revision:	https://reviews.freebsd.org/D24820

Changes:
  head/games/libretro-2048/Makefile
  head/games/libretro-2048/distinfo
  head/games/libretro-beetle_bsnes/Makefile
  head/games/libretro-beetle_bsnes/distinfo
  head/games/libretro-beetle_gba/Makefile
  head/games/libretro-beetle_gba/distinfo
  head/games/libretro-beetle_lynx/Makefile
  head/games/libretro-beetle_lynx/distinfo
  head/games/libretro-beetle_ngp/Makefile
  head/games/libretro-beetle_ngp/distinfo
  head/games/libretro-beetle_pce_fast/Makefile
  head/games/libretro-beetle_pce_fast/distinfo
  head/games/libretro-beetle_pcfx/Makefile
  head/games/libretro-beetle_pcfx/distinfo
  head/games/libretro-beetle_psx/Makefile
  head/games/libretro-beetle_psx/distinfo
  head/games/libretro-beetle_supergrafx/Makefile
  head/games/libretro-beetle_supergrafx/distinfo
  head/games/libretro-beetle_vb/Makefile
  head/games/libretro-beetle_vb/distinfo
  head/games/libretro-beetle_wswan/Makefile
  head/games/libretro-beetle_wswan/distinfo
  head/games/libretro-bluemsx/Makefile
  head/games/libretro-bluemsx/distinfo
  head/games/libretro-desmume2015/Makefile
  head/games/libretro-desmume2015/distinfo
  head/games/libretro-dosbox/Makefile
  head/games/libretro-dosbox/distinfo
  head/games/libretro-emux/Makefile
  head/games/libretro-emux/distinfo
  head/games/libretro-fbalpha/Makefile
  head/games/libretro-fbalpha/distinfo
  head/games/libretro-fceumm/Makefile
  head/games/libretro-fceumm/distinfo
  head/games/libretro-fuse/Makefile
  head/games/libretro-fuse/distinfo
  head/games/libretro-gambatte/Makefile
  head/games/libretro-gambatte/distinfo
  head/games/libretro-genesis_plus_gx/Makefile
  head/games/libretro-genesis_plus_gx/distinfo
  head/games/libretro-gpsp/Makefile
  head/games/libretro-gpsp/distinfo
  head/games/libretro-gw/Makefile
  head/games/libretro-gw/distinfo
  head/games/libretro-handy/Makefile
  head/games/libretro-handy/distinfo
  head/games/libretro-hatari/Makefile
  head/games/libretro-hatari/distinfo
  head/games/libretro-mame2000/Makefile
  head/games/libretro-mame2000/distinfo
  head/games/libretro-mame2003/Makefile
  head/games/libretro-mame2003/distinfo
  head/games/libretro-mame2003_plus/Makefile
  head/games/libretro-mame2003_plus/distinfo
  head/games/libretro-mgba/Makefile
  head/games/libretro-mgba/distinfo
  head/games/libretro-nestopia/Makefile
  head/games/libretro-nestopia/distinfo
  head/games/libretro-nxengine/Makefile
  head/games/libretro-nxengine/distinfo
  head/games/libretro-o2em/Makefile
  head/games/libretro-o2em/distinfo
  head/games/libretro-opera/Makefile
  head/games/libretro-opera/distinfo
  head/games/libretro-pcsx_rearmed/Makefile
  head/games/libretro-pcsx_rearmed/distinfo
  head/games/libretro-picodrive/Makefile
  head/games/libretro-picodrive/distinfo
  head/games/libretro-prboom/Makefile
  head/games/libretro-prboom/distinfo
  head/games/libretro-prosystem/Makefile
  head/games/libretro-prosystem/distinfo
  head/games/libretro-quicknes/Makefile
  head/games/libretro-quicknes/distinfo
  head/games/libretro-scummvm/Makefile
  head/games/libretro-scummvm/distinfo
  head/games/libretro-snes9x/Makefile
  head/games/libretro-snes9x/distinfo
  head/games/libretro-snes9x2005/Makefile
  head/games/libretro-snes9x2005/distinfo
  head/games/libretro-snes9x2010/Makefile
  head/games/libretro-snes9x2010/distinfo
  head/games/libretro-stella2014/Makefile
  head/games/libretro-stella2014/distinfo
  head/games/libretro-tgbdual/Makefile
  head/games/libretro-tgbdual/distinfo
  head/games/libretro-tyrquake/Makefile
  head/games/libretro-tyrquake/distinfo
  head/games/libretro-uae/Makefile
  head/games/libretro-uae/distinfo
  head/games/libretro-vbanext/Makefile
  head/games/libretro-vbanext/distinfo
  head/games/libretro-vecx/Makefile
  head/games/libretro-vecx/distinfo
  head/games/libretro-virtualjaguar/Makefile
  head/games/libretro-virtualjaguar/distinfo
Comment 13 Loïc Bartoletti freebsd_committer 2020-05-16 06:07:50 UTC
Committed, Thanks!