Bug 246073 - devel/boost-python-libs :openblas conflicts with cblas
Summary: devel/boost-python-libs :openblas conflicts with cblas
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: FreeBSD Office Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-01 07:32 UTC by gelonnov
Modified: 2020-05-02 09:02 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (office)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gelonnov 2020-05-01 07:32:50 UTC
# portupgrade py27-boost-libs
......
===>   Registering installation for openblas-0.3.7_3,1 as automatic
Installing openblas-0.3.7_3,1...
pkg-static: openblas-0.3.7_3,1 conflicts with cblas-1.0_12 (installs files into the same place).  Problematic file: /usr/local/include/cblas.h
*** Error code 70

Stop.
make[7]: stopped in /mnt/download/system/ports/math/openblas
*** Error code 1

Stop.
make[6]: stopped in /usr/ports/math/openblas
*** Error code 1

Stop.
make[5]: stopped in /mnt/download/system/ports/math/suitesparse
*** Error code 1

Stop.
make[4]: stopped in /usr/ports/math/suitesparse
*** Error code 1

Stop.
make[3]: stopped in /mnt/download/system/ports/math/py-numpy
*** Error code 1

Stop.
make[2]: stopped in /usr/ports/math/py-numpy
*** Error code 1

Stop.
make[1]: stopped in /mnt/download/system/ports/devel/boost-python-libs
*** Error code 1

Stop.
make: stopped in /mnt/download/system/ports/devel/boost-python-libs
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20200501-82054-uuvbvn env UPGRADE_TOOL=portupgrade UPGRADE_PORT=py27-boost-libs-1.72.0 UPGRADE_PORT_VER=1.72.0 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! devel/boost-python-libs (py27-boost-libs-1.72.0)      (unknown build error)
Comment 1 Jan Beich freebsd_committer 2020-05-01 20:55:11 UTC
Looks like a pilot error. Deinstall math/cblas then try again.
Comment 2 gelonnov 2020-05-02 08:58:20 UTC
(In reply to Jan Beich from comment #1)
Many thanks!
math/cblas was installed math/py-numpy
I needed OPTIONS_FILE_SET+=OPENBLAS in the file /var/db/ports/math_py-numpy/options
Everything has become good.