Bug 246136 - www/gitlab-ce: Does not post configure
Summary: www/gitlab-ce: Does not post configure
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Matthias Fechner
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-03 03:55 UTC by gdinolt
Modified: 2020-05-17 18:33 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (mfechner)


Attachments
output describing two problems in gitlab-ce after final installation process (4.74 KB, text/plain)
2020-05-03 03:55 UTC, gdinolt
no flags Details
Output log of installation of gitlab-ce following web instructions (667.99 KB, text/plain)
2020-05-05 02:59 UTC, gdinolt
no flags Details
"script" Output from vagrant/VirtualBox-ose install of gitlab-ce (674.10 KB, text/plain)
2020-05-05 19:37 UTC, gdinolt
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description gdinolt 2020-05-03 03:55:27 UTC
Created attachment 214045 [details]
output describing two problems in gitlab-ce after final installation process

gitlab-ce-12.9.5 does install all the files from a ports build from ports r533707, but the system does not work following the instructions in 

https://gitlab.fechner.net/mfechner/Gitlab-docu/blob/master/install/12.9-freebsd.md

as directed in the pkg-message. After completing the installation process described in the web page above, attempts to access the system result in "500 Message" "Whoops, something went wrong on our end." on the screen with the Gitlab orange logo. 


The installation seems to have failed.  I have included error messages in the attachment below.  One is the output from the final "gitlab:check" and the other is from the only log file that seems to indicate a problem, missing webpack files. 

I made only 1 change to the config/gitlab.yml file, and followed the instructions carefully.

I am running in an iocage jail on FreeBSD-12.1 

I previously tried versions 12.9.3 and 12.9.4 with the same results both from a ports build and from packages.
Comment 1 Mikael Urankar freebsd_committer 2020-05-03 09:41:49 UTC
It's not really clear if you followed the complete installation process, especially point 'Compile Assets'?
Comment 2 gdinolt 2020-05-04 15:07:52 UTC
(In reply to Mikael Urankar from comment #1)
Yes, I followed the complete installation process including the 
"Compile Assets"
Comment 3 gdinolt 2020-05-04 17:38:18 UTC
I should add that when I did the compile I saw several warning reports including more advanced ruby gems than was requested.  

If required, I can redo and regenerate the output from the compile and post it.
Comment 4 Matthias Fechner freebsd_committer 2020-05-04 19:15:17 UTC
Please start with a fresh installation and post to output of all commands from the manual.
Make sure you environment is clear, you can deinstall everything be using:
pkg delete gitlab-ce
pkg autoremove
pkg clean -a

Make sure no rubygem port is installed:
pkg info |grep rubygem

Then start from the beginning and give us the output of the commands.

The warning are caused by upstream updates, but they do not cause any problems for me.
Comment 5 gdinolt 2020-05-05 02:59:05 UTC
Created attachment 214138 [details]
Output log of installation of gitlab-ce following web instructions

This is a slightly edited "script" of the installation of gitlab-ce-12.9.5.  
I removed details of the pkg installations and pkg-message files.  

I did a copy and past of the lines from the listed web page.

The results were the same as I reported.  

Be happy to provide more info if requested.
Comment 6 Matthias Fechner freebsd_committer 2020-05-05 11:29:08 UTC
I have a vagrant script that starts a virtual machine, installs there FreeBSD 12.1 and installs gitlab, following what is described in the installation manual.

If you like, you can try the vagrant script:
https://gitlab.fechner.net/mfechner/Gitlab-vagrant

Make sure you use the correct git branch (see README.md).

So I cannot reproduce your problem. It could be, that your local FreeBSD installation is broken or has installed packages that collide with gitlab-ce or you have other files on your system not installed by pkg.

I see a out of swap space warning there and the kernel kills processes.
It seems that the new version requires more resources, I will try to do some more checks the next days.
Comment 7 gdinolt 2020-05-05 19:37:57 UTC
Created attachment 214170 [details]
"script" Output from vagrant/VirtualBox-ose install of gitlab-ce
Comment 8 gdinolt 2020-05-05 19:38:26 UTC
I tried your vagrant vm and followed the directions in the README.md file.

The VM installed and gitlab-ce installed using the ansible tool as expected.  Unfortunately, when I tried to connect to the server at 

http://localhost:10080

I still got the 500 Message from nginx with the Gitlab logo. The browser (firefox) did redirect to the login page. (Same in chromium) 

I have included the "script" of the session with removal of the details of the removed tgz files.  You can see, at the end of the file, that the webpack was requested but not installed.

Not clear to me why it works for you inside VirtualBox but doesn't for me. You would think inside the VirtualBox environment everything would be the same for both of us. 

I don't suppose it could be a "locale" problem?

Thanks for your suggestions and support.  Please let me know if there is other testing I can do.
Comment 9 Matthias Fechner freebsd_committer 2020-05-06 09:21:07 UTC
I reported this bug now upstream:
https://gitlab.com/gitlab-org/gitlab/-/issues/216740
Comment 10 Guillaume Bibaut 2020-05-11 19:12:15 UTC
I'm not really sure how it would help, and I don't think it would, but I'm having the same problem on a production serveur with 64GB of memory.
The compile assests is growing up until there's no more memory and swap, then either some processes crash, or the compile fails silently with no exit code (exit code was 0).
I'm also following the issue on gitlab.com.
Comment 11 Matthias Fechner freebsd_committer 2020-05-12 07:52:00 UTC
For me there is a clear error message that the kernel killed the process the asset compile is running.
It seems that the gitlab asset compile does not handle this case and it seems like the step is finished. But it is not and this is the reason why you see a 500 error if you try to access gitlab. Just check your /var/log/messages, there you see the information.

Is is also the reason why I reported it on Gitlab.

If you want to provide more information add this to the gitlab issue (on there site), please.

The more people answer in there issue tracker, the more attention this issue will receive and hopefully they will fix it.

I will try to do test with version 13, maybe they fixed on this version already something. Version 13 should be released in about 2 weeks.
Comment 12 Matthias Fechner freebsd_committer 2020-05-15 15:42:59 UTC
The problem is caused by an upgrade of textproc/rubygem-sassc from version 2.2.1 to 2.3.0.

I downgraded it:
https://gitlab.fechner.net/mfechner/Gitlab/-/commit/dd04651deb0d423cebd58728d7fb86fc0c7809eb

And that fixed it for me.
Can you please try this too?
Comment 13 Guillaume Bibaut 2020-05-15 21:45:26 UTC
(In reply to Matthias Fechner from comment #12)
Since it seems you are using gitlab-ce 12.10.3, it may make sense it's working.
But for 12.9.5, sadly it is still memory exhausting.
I've compiled rubgem-sassc 2.2.1 with your patches and installed it.
I've moved the /usr/local/www/gitlab-ce away, reinstalled 12.9.5 from package, and reapplied my configuration files on top. Then I started again from the 'gettext:compile' line.
Building 12.10.3 on this server, and then upgrading from 12.9 to 12.10 seems a bit too much for me.
What do you think about it?
Comment 14 gdinolt 2020-05-16 03:51:22 UTC
(In reply to Matthias Fechner from comment #12)
I followed your directions,  patched textproc/rubygem-sassc, compiled rubygem-sassc, installed gitalb-ce from ports, followed your installation directions and the system seems to work now. I can log in, create projects, etc.  The gitlab-ce version from ports is 12.9.5. 

I did this installation in a jail that was clean. I updated the packages and installed https://ports.svn/org/ports/head into ports (.  The rubygem-sassc I installed was from ports r535342 tree. Ruby, rubygem and some of the other ports were compiled from ports. 

This apparently fixes my problem. Thank you.
Comment 15 Matthias Fechner freebsd_committer 2020-05-16 07:46:59 UTC
(In reply to gdinolt from comment #14)
Thanks for confirmation. I will contact the maintainer of textproc/rubygem-sassc so we can find a solution for it.
It seems that such a problem is already reported here:
https://github.com/sass/sassc-ruby/issues/201

And maybe this can fix it:
https://github.com/sass/sassc-ruby/pull/199

But lets wait what sunpoet tell about this as he is the maintainer of the port.
Comment 16 Guillaume Bibaut 2020-05-16 08:34:18 UTC
I've tried complete reinstall (complete cleanup of ruby and its folders before hand), and reinstalled rubygem-sassc 2.2.1 from ports.
It is now installed and working. 

But I had to some minitest gem not installed(?):
- start a bundle install as git user to get the required minitest gem
- edit the Gemfile.lock to replace sassc 2.30 with sassc 2.2.1
- start a bundle install as git user again and verified the log I had sassc 2.2.1 listed
- install from your documentation

Thank you for your time.
I guess I'll always get some weird bug :)
Comment 17 Matthias Fechner freebsd_committer 2020-05-17 18:33:35 UTC
Should be fixed now by this commit:
https://svnweb.freebsd.org/ports?view=revision&revision=535562