Bug 246156 - sysutils/memfetch: fix BROKEN (size mismatch)
Summary: sysutils/memfetch: fix BROKEN (size mismatch)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Rene Ladan
URL:
Keywords: easy, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2020-05-04 04:19 UTC by Chris Hutchinson
Modified: 2020-05-22 19:50 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (onatan)
portmaster: maintainer-feedback?


Attachments
svn diff to fix sysutils/memfetch (1.53 KB, patch)
2020-05-04 04:19 UTC, Chris Hutchinson
portmaster: maintainer-approval?
Details | Diff
QA log for sysutils/memfetch (2.31 KB, text/plain)
2020-05-04 04:21 UTC, Chris Hutchinson
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Hutchinson 2020-05-04 04:19:16 UTC
Created attachment 214081 [details]
svn diff to fix sysutils/memfetch

This port is marked BROKEN because the author(s)
of the source changed the source file WITHOUT
bumping the VERSION number in April of 2007:

--- /usr/ports/distfiles/memfetch/memfetch.c	2003-10-20 11:04:45.000000000 -0700
+++ ./memfetch/memfetch.c	2007-04-03 13:13:24.000000000 -0700
@@ -280,7 +280,7 @@
             st,len);
 
     if (avoid_mmap) writeptr=MAP_FAILED; else {      
-      for (i=st;i<=en;i+=PAGE_SIZE) ptrace(PTRACE_PEEKDATA,tracepid,i,0);
+      for (i=st;i<en;i+=PAGE_SIZE) ptrace(PTRACE_PEEKDATA,tracepid,i,0);
       writeptr=mmap(0,len,PROT_READ,MAP_PRIVATE,memfile,st);
     }

The svn diff attached to this pr(1) acknowledges that change,
and changes:

Makefile
distinfo
files/patch-memfetch.c

which fixes this port.
Attached to this pr, are an svn diff, and a QA log.

Thats it. Thanks!
Comment 1 Chris Hutchinson 2020-05-04 04:21:22 UTC
Created attachment 214082 [details]
QA log for sysutils/memfetch

QA log that proves the svn diff attached to this pr(1)
works as intended.
Comment 2 commit-hook freebsd_committer 2020-05-20 19:08:53 UTC
A commit references this bug:

Author: rene
Date: Wed May 20 19:08:11 UTC 2020
New revision: 536017
URL: https://svnweb.freebsd.org/changeset/ports/536017

Log:
  sysutils/memfetch: unbreak and unexpire

  Upstream changed a source file without a version bump (back in 2007)

  PR:		246156
  Submitted by:	Chris Hutchinson
  Approved by:	maintainer timeout (onatan@gmail.com, 2 weeks)
  MFH:		2020Q2

Changes:
  head/sysutils/memfetch/Makefile
  head/sysutils/memfetch/distinfo
  head/sysutils/memfetch/files/patch-memfetch.c
Comment 3 commit-hook freebsd_committer 2020-05-22 19:50:26 UTC
A commit references this bug:

Author: rene
Date: Fri May 22 19:50:02 UTC 2020
New revision: 536240
URL: https://svnweb.freebsd.org/changeset/ports/536240

Log:
  MFH: r536017

  sysutils/memfetch: unbreak and unexpire

  Upstream changed a source file without a version bump (back in 2007)

  PR:		246156
  Submitted by:	Chris Hutchinson
  Approved by:	maintainer timeout (onatan@gmail.com, 2 weeks)

  Approved by:	ports-secteam (joneum)

Changes:
_U  branches/2020Q2/
  branches/2020Q2/sysutils/memfetch/Makefile
  branches/2020Q2/sysutils/memfetch/distinfo
  branches/2020Q2/sysutils/memfetch/files/patch-memfetch.c