Bug 246217 - multimedia/libx264: distinfo missing entry after ports r533939
Summary: multimedia/libx264: distinfo missing entry after ports r533939
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Piotr Kubaj
URL:
Keywords: needs-patch, regression
: 246210 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-05 09:05 UTC by Jack
Modified: 2020-05-18 04:55 UTC (History)
3 users (show)

See Also:
koobs: maintainer-feedback+
koobs: merge-quarterly?


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jack 2020-05-05 09:05:23 UTC
libx264 is missing distinfo

/usr/ports/multimedia/libx264 # ls
Makefile        pkg-plist


/usr/ports/multimedia/libx264 # make
===>  License GPLv2 accepted by the user
===>   libx264-0.159.2999 depends on file: /usr/local/sbin/pkg - found
=> x264/example.y4m.bz2 is not in /usr/ports/multimedia/libx264/../x264/distinfo.
=> Either /usr/ports/multimedia/libx264/../x264/distinfo is out of date, or
=> x264/example.y4m.bz2 is spelled incorrectly.
*** Error code 1

Stop.
make[1]: stopped in /usr/ports/multimedia/libx264
*** Error code 1

Stop.
make: stopped in /usr/ports/multimedia/libx264
Comment 1 Jan Beich freebsd_committer 2020-05-05 11:59:25 UTC
*** Bug 246210 has been marked as a duplicate of this bug. ***
Comment 2 commit-hook freebsd_committer 2020-05-05 12:12:30 UTC
A commit references this bug:

Author: pkubaj
Date: Tue May  5 12:11:43 UTC 2020
New revision: 534077
URL: https://svnweb.freebsd.org/changeset/ports/534077

Log:
  multimedia/x264: add missing distinfo

  Removed in r533939.

  PR:		246217
  Reported by:	xxjack12xx@gmail.com
  Approved by:	portmgr (blanket: just fix it)

Changes:
  head/multimedia/x264/distinfo