Bug 246220 - graphics/wayland: wayland-egl: could not open /dev/dri/renderD
Summary: graphics/wayland: wayland-egl: could not open /dev/dri/renderD
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-05 13:04 UTC by Ting-Wei Lan
Modified: 2020-06-06 18:08 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ting-Wei Lan 2020-05-05 13:04:55 UTC
I don't know where the bug came from. If I chose the wrong port, please move it to the correct one.

I was trying to run mutter as a nested Wayland compositor under Xorg, and I found Xwayland just showed an error and hung. It could not show any X11 window.

wayland-egl: could not open /dev/dri/renderD (No such file or directory)

There is no /dev/dri/renderD on the system, and I don't know why it wants the file. Running eglinfo also shows the same error:

libEGL warning: wayland-egl: could not open /dev/dri/renderD (No such file or directory)

It seems to be a problem of the Wayland compositor, except that it isn't limited to a single Wayland compositor implementation. Both mutter and sway have the same issue. Sometimes they even report errors with weird names such as /dev/dri/renderDvblank_mode and /dev/dri/renderDbo_reuse.

If I create the symlink /dev/dri/renderD -> renderD128, Xwayland can work properly.
Comment 1 Ka Ho Ng 2020-05-09 18:39:54 UTC
Could you try the libdrm from https://github.com/khng300/drm/tree/2.4.101-updating ?

I backported the drm node changes related to FreeBSD from the tip of their repository to 2.4.101.

The ports change related can be fetched from https://github.com/khng300/freebsd-ports/commit/845891b72cfeaa3c1d98b190624312d965b7ac0b
Comment 2 Jan Beich freebsd_committer 2020-06-02 11:33:20 UTC
(In reply to Ting-Wei Lan from comment #0)
> libEGL warning: wayland-egl: could not open /dev/dri/renderD (No such file or directory)

Can you still reproduce after ports r537533? libdrm no longer uses major/minor numbers on FreeBSD for things like drmGetDeviceNameFromFd2.
Comment 3 Ting-Wei Lan 2020-06-06 18:08:24 UTC
(In reply to Jan Beich from comment #2)
No, I cannot reproduce it after the update and I think it has been fixed.