Bug 246312 - make buildkernel fails on sys/dev/kbdmux/kbdmux.c at r360808 (r360560 was ok)
Summary: make buildkernel fails on sys/dev/kbdmux/kbdmux.c at r360808 (r360560 was ok)
Status: Closed Unable to Reproduce
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.1-STABLE
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-08 15:59 UTC by Philippe Michel
Modified: 2020-06-01 15:52 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Michel 2020-05-08 15:59:06 UTC
At r360808, make buildkernel fails with:

--- kbdmux.o ---
/usr/src/sys/dev/kbdmux/kbdmux.c:464:10: error: use of undeclared identifier 'key_map'; did you mean 'keymap'?
                bcopy(&key_map, keymap, sizeof(key_map));
                       ^~~~~~~
This is apparently related to the use of the following options in the config file:
options         KBDMUX_DFLT_KEYMAP
makeoptions     KBDMUX_DFLT_KEYMAP=fr.acc

If I remove them, the build completes successfully, but it did with them enabled at least until r360560.
Comment 1 Philippe Michel 2020-05-13 19:52:55 UTC
I retried this build since then with KBDMUX_DFLT_KEYMAP enabled (at r361008 but there does not seen to have been relevant changes since my initial report), and have been unable to reproduce the issue.

Maybe I somehow blundered the first time. Another possibility would be some race issue (I build with make -j 2)
Comment 2 Mark Johnston freebsd_committer 2020-06-01 15:52:33 UTC
(In reply to Philippe Michel from comment #1)
I will close the bug for now, then.  If it occurs again, please re-open, and provide the contents of kbdmuxmap.h from the kernel object directory.