Bug 246320 - audio/supercollider: Update to 3.11.0
Summary: audio/supercollider: Update to 3.11.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kai Knoblich
URL:
Keywords: buildisok, patch
Depends on:
Blocks:
 
Reported: 2020-05-09 05:49 UTC by shamaz.mazum
Modified: 2020-06-17 08:53 UTC (History)
3 users (show)

See Also:
ports: maintainer-feedback+
kai: merge-quarterly+


Attachments
Port patch (14.44 KB, patch)
2020-05-09 05:49 UTC, shamaz.mazum
kai: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description shamaz.mazum 2020-05-09 05:49:33 UTC
Created attachment 214298 [details]
Port patch

Please update SuperCollider to 3.11.0

My changes also unbreak this port.
Comment 1 Automation User 2020-05-11 21:51:36 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/144528668
Comment 2 Neal Nelson 2020-05-12 15:19:44 UTC
I've done a poudriere test run and it passes (It took almost two days!). I'm now trying to build it normally and the cmake configuration is failing, which is odd.

I get the following error:

-- Could NOT find YAMLCPP (missing: YAMLCPP_INCLUDE_DIR YAMLCPP_LIBRARY)
Comment 3 shamaz.mazum 2020-05-12 17:34:01 UTC
That's strange. Do you have yaml-cpp package installed as a dependency after the failure?

Also, there is a bundled version of yaml-cpp in supercollider itself (earlier ports use this vresion). Maybe I should use it?
Comment 4 Neal Nelson 2020-06-09 07:23:42 UTC
I think it won't build because yaml-cpp03 is installed as a dependency of another port.

Everything build OK in poudriere, so it should be fine.
Comment 5 Kai Knoblich freebsd_committer 2020-06-14 18:45:34 UTC
(In reply to shamaz.mazum from comment #0)
(In reply to Neal Nelson from comment #2)

Thank you both for the patch and the testing. The ports builds fine and I'm doing some build tests against Qt 5.15.0, which should land in a few days, to make sure, that there won't be pkg-fallouts then.

I've one suggestion regarding the AVAHI option:

If the AVAHI option is set then the CMake flag "NO_AVAHI" is set to false and the binaries are not linked against the avahi libraries but the latter ones are installed anyway.

I assume, the opposite is meant. Thus I would change "AVAHI_CMAKE_BOOL" to "AVAHI_CMAKE_BOOL_OFF" to get the desired results.

If this was intended, the attached patch need not to be updated as it's only a minor fix which already is included in my local repository.
Comment 6 shamaz.mazum 2020-06-15 05:46:26 UTC
> I assume, the opposite is meant. Thus I would change "AVAHI_CMAKE_BOOL" to "AVAHI_CMAKE_BOOL_OFF" to get the desired results.

Yes, thanks for correction. That's what I meant.
Comment 7 Kai Knoblich freebsd_committer 2020-06-15 15:48:08 UTC
Comment on attachment 214298 [details]
Port patch

^ Triage: Setting maintainer-approval on patch accordingly as given in comment #4.
Comment 8 commit-hook freebsd_committer 2020-06-15 15:51:10 UTC
A commit references this bug:

Author: kai
Date: Mon Jun 15 15:50:13 UTC 2020
New revision: 538903
URL: https://svnweb.freebsd.org/changeset/ports/538903

Log:
  audio/supercollider: Update to 3.11.0

  * Introduce additional default option AVAHI to make the use of the Avahi
    libraries optional.

  * Remove one patch and the whole patching via "post-patch" - both is no
    longer needed.

  * While I'm here: Prepare the port for Qt 5.15.0

  Changelog:

  https://github.com/supercollider/supercollider/releases/tag/Version-3.11.0

  PR:		246320
  Submitted by:	shamaz.mazum@gmail.com
  Approved by:	Neal Nelson <ports@nicandneal.net> (maintainer)
  MFH:		2020Q2 (blanket: unbreak broken port)

Changes:
  head/audio/supercollider/Makefile
  head/audio/supercollider/distinfo
  head/audio/supercollider/files/patch-QtCollider_primitives_prim__QPen.cpp
  head/audio/supercollider/files/patch-QtCollider_widgets_QcGraph.cpp
  head/audio/supercollider/files/patch-QtCollider_widgets_QcLevelIndicator.cpp
  head/audio/supercollider/files/patch-QtCollider_widgets_QcMultiSlider.cpp
  head/audio/supercollider/files/patch-QtCollider_widgets_QcScopeShm.cpp
  head/audio/supercollider/files/patch-QtCollider_widgets_soundfileview_view.cpp
  head/audio/supercollider/files/patch-external__libraries_CMakeLists.txt
  head/audio/supercollider/pkg-plist
Comment 9 Kai Knoblich freebsd_committer 2020-06-15 15:53:55 UTC
(In reply to shamaz.mazum from comment #6)

Committed, thank you for the quick feedback and the patch!

I'll try to merge the changes into the 2020Q2 branch because the port is still broken there. Test builds are running at the moment.
Comment 10 commit-hook freebsd_committer 2020-06-17 08:44:15 UTC
A commit references this bug:

Author: kai
Date: Wed Jun 17 08:43:49 UTC 2020
New revision: 539407
URL: https://svnweb.freebsd.org/changeset/ports/539407

Log:
  MFH: r538903

  audio/supercollider: Update to 3.11.0

  * Introduce additional default option AVAHI to make the use of the Avahi
    libraries optional.

  * Remove one patch and the whole patching via "post-patch" - both is no
    longer needed.

  * While I'm here: Prepare the port for Qt 5.15.0

  Changelog:

  https://github.com/supercollider/supercollider/releases/tag/Version-3.11.0

  PR:		246320
  Submitted by:	shamaz.mazum@gmail.com
  Approved by:	Neal Nelson <ports@nicandneal.net> (maintainer)

  Approved by:	ports-secteam build fix blanket

Changes:
_U  branches/2020Q2/
  branches/2020Q2/audio/supercollider/Makefile
  branches/2020Q2/audio/supercollider/distinfo
  branches/2020Q2/audio/supercollider/files/patch-QtCollider_primitives_prim__QPen.cpp
  branches/2020Q2/audio/supercollider/files/patch-QtCollider_widgets_QcGraph.cpp
  branches/2020Q2/audio/supercollider/files/patch-QtCollider_widgets_QcLevelIndicator.cpp
  branches/2020Q2/audio/supercollider/files/patch-QtCollider_widgets_QcMultiSlider.cpp
  branches/2020Q2/audio/supercollider/files/patch-QtCollider_widgets_QcScopeShm.cpp
  branches/2020Q2/audio/supercollider/files/patch-QtCollider_widgets_soundfileview_view.cpp
  branches/2020Q2/audio/supercollider/files/patch-external__libraries_CMakeLists.txt
  branches/2020Q2/audio/supercollider/pkg-plist
Comment 11 Kai Knoblich freebsd_committer 2020-06-17 08:53:48 UTC
Committed to the 2020Q2 branch, all done!