Bug 246373 - www/tomcat-native: work around issues with LibreSSL in 1.1.24
Summary: www/tomcat-native: work around issues with LibreSSL in 1.1.24
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Alex Dupre
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-11 14:38 UTC by Michael Osipov
Modified: 2020-05-13 08:33 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (ale)


Attachments
First patch (2.11 KB, patch)
2020-05-11 19:53 UTC, Michael Osipov
no flags Details | Diff
Second patch (2.04 KB, patch)
2020-05-11 19:54 UTC, Michael Osipov
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Osipov 2020-05-11 14:38:18 UTC
The current libtcnative has one regression and one nag. Please apply the following patches when LibreSSL is used:

* Revert https://github.com/apache/tomcat-native/commit/b8649e81458194d70667952d9e26df82a79c773f
* Apply https://github.com/apache/tomcat-native/commit/14f47ffea3105db6f17bee4a029eaf73e94ddee4

and bump the port revision
Comment 1 Alex Dupre freebsd_committer 2020-05-11 15:14:15 UTC
Can they be reverted/applied also when openssl is used?
Comment 2 Michael Osipov 2020-05-11 16:01:49 UTC
(In reply to Alex Dupre from comment #1)

From the top of my head: Yes, but I need to verify to be 100% sure. Will do this evening.
Comment 3 Michael Osipov 2020-05-11 19:53:18 UTC
I have branched off 1.2.24 and cherry picked those two commits. Ran all Tomcat tests on 12.1-STABLE with OpenSSL 1.0.2 from source, OpenSSL 1.1.1 from base and LibreSSL from master and everything works. Except org.apache.tomcat.util.net.TestSSLHostConfigCompat. This one crashes due to incompat between OpenSSL/LibreSSL, but that this OK.

Find the required patches attached.
Comment 4 Michael Osipov 2020-05-11 19:53:45 UTC
Created attachment 214392 [details]
First patch
Comment 5 Michael Osipov 2020-05-11 19:54:10 UTC
Created attachment 214393 [details]
Second patch
Comment 6 Michael Osipov 2020-05-11 19:55:56 UTC
Please ignore the hunks on changelog.xml. They are irrelevant.
Comment 7 Alex Dupre freebsd_committer 2020-05-13 07:55:37 UTC
Thanks Michael!
Comment 8 commit-hook freebsd_committer 2020-05-13 07:56:23 UTC
A commit references this bug:

Author: ale
Date: Wed May 13 07:55:25 UTC 2020
New revision: 535088
URL: https://svnweb.freebsd.org/changeset/ports/535088

Log:
  Fix build with libressl.

  PR:		246373
  Submitted by:	Michael Osipov <michael.osipov@siemens.com>

Changes:
  head/www/tomcat-native/Makefile
  head/www/tomcat-native/files/
  head/www/tomcat-native/files/patch-include_ssl__private.h
  head/www/tomcat-native/files/patch-src_ssl.c
Comment 9 Michael Osipov 2020-05-13 08:33:15 UTC
Very much welcome! I have already the next series of issues with LibreSSL identified and will put them upstream.

Hope to earn port commit bit at some point in future.