Bug 246447 - [NEW PORT] net-mgmt/zabbix5-*: Zabbix Ports (5.0.X)
Summary: [NEW PORT] net-mgmt/zabbix5-*: Zabbix Ports (5.0.X)
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Danilo G. Baio
URL: https://www.zabbix.com/rn/rn5.0.0
Keywords: feature, needs-patch, needs-qa
: 246555 (view as bug list)
Depends on:
Blocks:
 
Reported: 2020-05-13 20:22 UTC by VVD
Modified: 2020-06-03 22:52 UTC (History)
7 users (show)

See Also:


Attachments
zabbix 5.0 (93.02 KB, text/plain)
2020-05-19 06:46 UTC, Juraj Lutter
no flags Details
zabbix 5.0 (93.03 KB, text/plain)
2020-05-19 07:07 UTC, Juraj Lutter
no flags Details
zabbix 5.0 suite diff (136.02 KB, patch)
2020-05-20 12:39 UTC, Juraj Lutter
no flags Details | Diff
zabbix 5.0 suite diff (152.43 KB, patch)
2020-05-26 20:38 UTC, Juraj Lutter
no flags Details | Diff
New port of Zabbix 5 (57.94 KB, patch)
2020-05-27 14:08 UTC, pg
pg: maintainer-approval+
Details | Diff
zabbix 5.0.1 (57.45 KB, patch)
2020-06-01 23:42 UTC, pg
pg: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description VVD 2020-05-13 20:22:17 UTC
11 May 2020
Zabbix Team is pleased to announce the availability of Zabbix 5.0.0.

https://www.zabbix.com/documentation/current/manual/installation/upgrade_notes_500
https://cdn.zabbix.com/zabbix/sources/stable/5.0/

BTW, 4.2 is unsupported upstream already.
Comment 1 Peter Kubica 2020-05-14 12:59:16 UTC
Please include Agent 2.
Comment 2 Juraj Lutter 2020-05-18 21:50:35 UTC
I've created:

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246555

I can also try agent2.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-05-19 02:57:02 UTC
Thank you Juraj

Could you please attach the patch from bug 246555 here please
Comment 4 Kubilay Kocak freebsd_committer freebsd_triage 2020-05-19 02:58:08 UTC
*** Bug 246555 has been marked as a duplicate of this bug. ***
Comment 5 Juraj Lutter 2020-05-19 06:46:07 UTC
Created attachment 214622 [details]
zabbix 5.0
Comment 6 Juraj Lutter 2020-05-19 07:07:31 UTC
Created attachment 214623 [details]
zabbix 5.0
Comment 7 Juraj Lutter 2020-05-19 07:08:01 UTC
(In reply to Juraj Lutter from comment #6)

This patch contains updated pkg-message.in
Comment 9 Danilo G. Baio freebsd_committer 2020-05-19 20:56:17 UTC
(In reply to Juraj Lutter from comment #7)

Hi Juraj.

Thanks for your work.

A few tweaks, instead of a shar file, please send a diff here, it will simplify things.

$ svn cp net-mgmt/zabbix4-server net-mgmt/zabbix5-server
$ svn cp net-mgmt/zabbix4-agent net-mgmt/zabbix5-agent
and go on ... 
then you just need to `svn diff net-mgmt/zabbix5*` and send the patch here.

Adjust conflicts;  MASTER_SITES as zabbix44;

The naming, please follow the standard of the other 20 Zabbix ports:
  zabbix3  — 3.0.X
  zabbix4  - 4.0.X
  zabbix42 - 4.2.X
  zabbix44 - 4.4.X
  zabbix5  - 5.0.X  <---
Comment 10 Juraj Lutter 2020-05-19 22:22:29 UTC
I have been able to run agent2:

https://files.wilbury.net/s/eZ3Fejj6P9zQtbL

It will require some more minor work, though (agent2 runs in foreground by default, it will require involvment of daemon(8), more FreeBSD-specific testing is need as well.)
Comment 11 Peter Kubica 2020-05-20 03:30:04 UTC
(In reply to Juraj Lutter from comment #10)

Thanks Juraj, great news.
Comment 12 Juraj Lutter 2020-05-20 12:39:49 UTC
Created attachment 214691 [details]
zabbix 5.0 suite diff

New zabbix 5.0 ports in diff format
Comment 13 Mikael Urankar freebsd_committer 2020-05-20 13:30:33 UTC
Do you have a phab account? I have a few remarks and it's easier to do it in phab.
Does agent2 build under poudriere?
Comment 14 Juraj Lutter 2020-05-20 13:35:26 UTC
phab link:

https://reviews.freebsd.org/D24926

agent2 does not build in poudriere (as of now), it requires some go modules that are being downloaded from the Internet amidst build. I'd be happy to see how to work arond this issue that is preventing agent2 from build in poudriere.
Comment 15 Mikael Urankar freebsd_committer 2020-05-20 13:53:16 UTC
(In reply to Juraj Lutter from comment #14)
Thanks for the phab review.

This is what I've done for zabbix-agent2:
https://github.com/MikaelUrankar/zabbix5/tree/master/zabbix50-agent2
Comment 16 Juraj Lutter 2020-05-23 19:45:41 UTC
I have fixed the agent2 build, see the diff in phabricator.
Comment 17 VVD 2020-05-26 18:10:21 UTC
5.0.1 released: https://cdn.zabbix.com/zabbix/sources/stable/5.0/
Comment 18 Juraj Lutter 2020-05-26 20:38:40 UTC
Created attachment 214890 [details]
zabbix 5.0 suite diff
Comment 19 Juraj Lutter 2020-05-26 20:40:10 UTC
Patch updated to 5.0.1.

It also contains zabbix-agent2 that will need more work. I suggest to review and commit it without agent2 for the time being, I am working on make it ready (to clean up Linux-isms where possible.)
Comment 20 pg 2020-05-27 14:08:52 UTC
Created attachment 214918 [details]
New port of Zabbix 5

Many people ask for a port with Zabbix 5. I think it's a good idea to commit it without agent2 now and continue to work further. I created the patch with Zabbix 5.0.1. I also fixed the use deprecated USE_PHP and other minor changes. It's build in poudriere without errors.
Comment 21 Mikael Urankar freebsd_committer 2020-05-29 13:36:04 UTC
So, who wants to be the maintainer?
Comment 22 pg 2020-05-29 13:42:46 UTC
I am ready, like the rest of the zabbix* ports.
Comment 23 Danilo G. Baio freebsd_committer 2020-05-29 14:30:55 UTC
(In reply to pg from comment #22)

I just want to highlight this, not directly to you but to all port maintainers:
https://www.freebsd.org/doc/en_US.ISO8859-1/articles/contributing/ports-contributing.html#maintain-port
...

- Send patches to upstream authors
  Agent2 patches needs to be send to upstream, and other bugs that are fixed here as well.

- Investigate bug reports and PRs related to your port
  Please, help in this, we have PR's (open) that need attention.

- Build test
  When you test a port, don't forget to test all the other OPTIONS (non default one's).

- Keep consistency
  It's not there, but please, keep consistency in all Zabbix ports.
  Usually people send patches for a specific version that they are using, you need to get that and incorporate in all other ports.
  I'm saying it because usually I'm the one who do this.

It's good to re-read this sometimes, you need time and dedication to maintain a lot of ports like the full set of Zabbix.

For all on CC list, thank you for all your efforts on Zabbix ports.
Comment 24 Mikael Urankar freebsd_committer 2020-06-01 13:55:49 UTC
@Danilo do you plan to commit it?
Comment 25 Danilo G. Baio freebsd_committer 2020-06-01 16:38:19 UTC
(In reply to Mikael Urankar from comment #24)

Hi Mikael.

I can't today, but if you have time, go for it.

Few points about attachment 214918 [details]:

pkg-message:
  "This is a Zabbix Standard release! ..."

That's wrong, this is a LTS release.

CONFLICTS needs to be adjusted.

Do the repocopy from the net-mgmt/zabbix4-* ports.

...


I was thinking in bug 245037 (it affects here as well), maybe just renaming bin/zabbix_js to bin/zabbix_proxy_js on zabbix*-proxy ports will help.
Comment 26 pg 2020-06-01 23:42:41 UTC
Created attachment 215152 [details]
zabbix 5.0.1

Fixed pkg-message and adjustement CONFLICTS. About bug 245037 I investigate tomorrow.
Comment 27 Danilo G. Baio freebsd_committer 2020-06-02 00:30:17 UTC
(In reply to pg from comment #26)

In CONFLICTS just this is better, it will fit whenever there is a new zabbix port:

From zabbix4-*
CONFLICTS=  zabbix[0-9][0-9]${PKGNAMESUFFIX} zabbix[0-35-9]${PKGNAMESUFFIX}

to zabbix5-*
CONFLICTS=  zabbix[0-9][0-9]${PKGNAMESUFFIX} zabbix[0-46-9]${PKGNAMESUFFIX}


don't need to update the patch.
Comment 28 commit-hook freebsd_committer 2020-06-03 22:51:12 UTC
A commit references this bug:

Author: dbaio
Date: Wed Jun  3 22:50:20 UTC 2020
New revision: 537856
URL: https://svnweb.freebsd.org/changeset/ports/537856

Log:
  New ports: net-mgmt/zabbix5-[agent|frontend|java|proxy|server]

  net-mgmt/zabbix4 -> net-mgmt/zabbix5

  What's new in Zabbix 5.0:
  https://www.zabbix.com/documentation/current/manual/introduction/whatsnew500

  PR:		246447
  Submitted by:	Juraj Lutter <juraj@lutter.sk>
  Submitted by:	pg@pakhom.spb.ru
  Reported by:	vvd@unislabs.com

Changes:
  head/net-mgmt/Makefile
  head/net-mgmt/zabbix5-agent/
  head/net-mgmt/zabbix5-agent/Makefile
  head/net-mgmt/zabbix5-frontend/
  head/net-mgmt/zabbix5-frontend/Makefile
  head/net-mgmt/zabbix5-java/
  head/net-mgmt/zabbix5-java/Makefile
  head/net-mgmt/zabbix5-proxy/
  head/net-mgmt/zabbix5-proxy/Makefile
  head/net-mgmt/zabbix5-server/
  head/net-mgmt/zabbix5-server/Makefile
  head/net-mgmt/zabbix5-server/distinfo
  head/net-mgmt/zabbix5-server/files/pkg-message.in
  head/net-mgmt/zabbix5-server/pkg-plist
  head/net-mgmt/zabbix5-server/pkg-plist.frontend
Comment 29 Danilo G. Baio freebsd_committer 2020-06-03 22:52:05 UTC
Keeping the current maintainer for consistency (same in all Zabbix ports).
Thank you all for the work.
Juraj, looking forward to see Agent2 here in the ports tree.