Bug 246499 - Intel hardware acceleration problem on Thinkpad t450s and others
Summary: Intel hardware acceleration problem on Thinkpad t450s and others
Status: New
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.1-RELEASE
Hardware: amd64 Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-16 11:59 UTC by Ivan Kovmir
Modified: 2020-05-19 14:34 UTC (History)
1 user (show)

See Also:


Attachments
This vdpauinfo output. (4.87 KB, text/plain)
2020-05-16 11:59 UTC, Ivan Kovmir
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Kovmir 2020-05-16 11:59:53 UTC
Created attachment 214547 [details]
This vdpauinfo output.

I own a thinkpad t450s.

Intel Core i7-5600U
Intel HD Graphics 5500 integrated into CPU

If I run 'env vblank_mode=0 glxgears', then gears are fine and smooth. They take ~15% of the CPU time while giving out 500FPS and ~34% when giving 2500FPS.

But vim and zathura are laggy. If scroll zathura, then Xorg starts consuming up to ~70% of the CPU time. Fire takes ~40% of the CPU time giving 60FPS.

'vainfo' gives no errors, but 'vdpauinfo' shows segmentation fault followed by a crash:
'[1]    51793 segmentation fault (core dumped)  vdpauinfo'.
There is also a new entry in dmesg after that: 'pid 34555 (vdpauinfo), jid 0, uid 1001: exited on signal 11 (core dumped)'. And, each time I run 'vdpauinfo', it creates a file named 'vdpauinfo.core', with the size of 1.6M.

'vainfo' output: https://pastebin.com/qMACR6qX
'vdpauinfo' output: as a script(1) result in the attachements
Xorg.0.log: https://pastebin.com/UYru3qEn
dmesg: https://pastebin.com/nMvUeQGL
vdpauinfo.core: https://transfer.sh/l2eQ3/vdpauinfo.core

I know a guy who faced the same issue with a relatively new thinkpad. So the issue seems to affect people with newer chipsets.