Bug 246529 - devel/binaryen: Update to 93
Summary: devel/binaryen: Update to 93
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Hiroki Tagato
URL:
Keywords: buildisok
Depends on:
Blocks:
 
Reported: 2020-05-17 18:50 UTC by Bethany Long
Modified: 2020-05-19 06:02 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (greg)


Attachments
binaryen93.patch (2.15 KB, patch)
2020-05-17 21:53 UTC, Greg V
greg: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Bethany Long 2020-05-17 18:50:51 UTC
Really we just need 91+. Current emscripten expects a new wasm-opt --version
format, which prevents new users (like me) from building their hello worlds:

% emcc -o hello.html hello.c
cache:INFO: generating system asset: generated_struct_info.json... (this will be cached in "/home/username/.emscripten_cache/wasm/generated_struct_info.json" for subsequent builds)
shared:ERROR: error parsing binaryen version (wasm-opt 90). Please check your binaryen installation (/usr/local/bin/wasm-opt)
FAIL: Compilation failed!

% wasm-opt --version
wasm-opt 90


This is the format it expects:

% wasm-opt --version
wasm-opt version 93


This is where upstream binaryen changed the --version format:
https://github.com/WebAssembly/binaryen/commit/4953bcc59085c49343c334ccc852fc5c0339c938#diff-0cdf1402e4de0d0e0a450c4f5558d589

This is where emscripten started expecting three tokens in wasm-opt's --version output:
https://github.com/emscripten-core/emscripten/commit/4fdb3053690170362c5f7c83a553149c8956d3c2#diff-b97059c38de7432017d59dee3e87bc72

---

Using previous upgrades (bug 238994, bug 243308) as a cheat sheet, to install
version 93 locally I updated DISTVERSION in the Makefile and distinfo, and
removed the patch in files/. Upstream version 93 seems to gate the git check
natively now, so I don't think our patch is required anymore.

% grep 93 *
distinfo:SHA256 (WebAssembly-binaryen-version_93_GH0.tar.gz) = a770a26dea4da4b33eee4a020f054196e9530cceeeff17b977e2bc6e4fd2dd7f
distinfo:SIZE (WebAssembly-binaryen-version_93_GH0.tar.gz) = 4244359
Makefile:DISTVERSION=   93

% ls files
%


Also, it doesn't look like there need to be any pkg-plist changes:

/usr/ports/devel/binaryen/work/.build% diff -u ../../pkg-plist <(find bin lib -type f | sort)
--- ../../pkg-plist     2019-07-06 11:08:27.000000000 -0700
+++ /tmp/zshrTNFvh      2020-05-17 11:40:41.263302000 -0700
@@ -8,5 +8,4 @@
 bin/wasm-reduce
 bin/wasm-shell
 bin/wasm2js
-include/binaryen-c.h
 lib/libbinaryen.so
Comment 1 Greg V 2020-05-17 21:53:23 UTC
Created attachment 214590 [details]
binaryen93.patch

Let's also switch to python3 while here :)
Comment 2 Automation User 2020-05-17 22:21:34 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/146933537
Comment 3 commit-hook freebsd_committer 2020-05-19 06:02:01 UTC
A commit references this bug:

Author: tagattie
Date: Tue May 19 06:01:08 UTC 2020
New revision: 535832
URL: https://svnweb.freebsd.org/changeset/ports/535832

Log:
  - Update to 93
  - Switch to python 3

  PR:		246529
  Submitted by:	Greg V <greg@unrelenting.technology>
  Reported by:	Bethany Long <bethanylong.x90@gmail.com>
  Approved by:	mentors (implicit)
  Changelog:	https://github.com/WebAssembly/binaryen/blob/version_93/CHANGELOG.md

Changes:
  head/devel/binaryen/Makefile
  head/devel/binaryen/distinfo
  head/devel/binaryen/files/
Comment 4 Hiroki Tagato freebsd_committer 2020-05-19 06:02:54 UTC
Committed, thanks!