Bug 246550 - www/firefox: Pulseaudio dont get pulled as dependency anymore?
Summary: www/firefox: Pulseaudio dont get pulled as dependency anymore?
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-18 18:18 UTC by Alexander Vereeken
Modified: 2020-05-22 20:31 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Vereeken 2020-05-18 18:18:12 UTC
Hello,

i have installed firefox from the latest repository and had the bug that i couldn't hear anything at soundcloud.com then I wanted to check if pulseaudio was running but pulseaudio wasn't pulled even though it should be installed, right? 

In any case soundcloud is working again by installing pulseaudio by hand.
Comment 1 Jan Beich freebsd_committer 2020-05-22 07:43:25 UTC
Historic reasons:
- Lazy bindings (libpulse.so is loaded via dlopen)
- ALSA/SNDIO is good enough for playback-only
- WebRTC wasn't popular until a few years ago
- Vocal minority (bug 216383)

Firefox didn't have sound probably because the backend selected by default wasn't configured properly. Did you read pkg-message?

For probing order see https://searchfox.org/mozilla-central/rev/06985b12a4ab/media/libcubeb/src/cubeb.c#188-226
Comment 2 Alexander Vereeken 2020-05-22 20:31:16 UTC
All right, thanks for the explanation.