Bug 246557 - Kernel panics on SSH with X forwarding enabled
Summary: Kernel panics on SSH with X forwarding enabled
Status: Closed DUPLICATE of bug 242913
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 12.1-STABLE
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-19 00:02 UTC by Ashish Gupta
Modified: 2020-05-19 13:42 UTC (History)
2 users (show)

See Also:


Attachments
Kernel crash dump info file (71.44 KB, text/plain)
2020-05-19 00:02 UTC, Ashish Gupta
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ashish Gupta 2020-05-19 00:02:10 UTC
Created attachment 214617 [details]
Kernel crash dump info file

Kernel panics with "Fatal trap 12: page fault while in kernel mode"

Steps to Reproduce:

1) SSH with X Forwarding enabled to a linux machine : ssh -y LinuxIP
2) Run wireshark on the ssh session
3) Kernel panic

Please see the core.txt file attachment for more details (truncated to fit).
Comment 1 Greg Veldman 2020-05-19 13:18:55 UTC
Looking at the backtrace, and having experienced similar issues myself, it appears this could be related to bug 242913.  It looks like the fix for this went into 12-STABLE in r356953 in January, but is not in 12.1-RELEASE.  I manually backported the fix into my kernel and have not had any such issues since.
Comment 2 Mark Johnston freebsd_committer 2020-05-19 13:42:46 UTC
(In reply to Greg Veldman from comment #1)
Indeed, this should already be fixed.  The crash report shows the kernel revision as r354552, so an update is required.

*** This bug has been marked as a duplicate of bug 242913 ***