Bug 246587 - textproc/p5-XML-LibXML: Update to 2.0205
Summary: textproc/p5-XML-LibXML: Update to 2.0205
Status: New
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-perl mailing list
URL: https://metacpan.org/release/XML-LibXML
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-20 00:10 UTC by Sergei Vyshenski
Modified: 2020-05-20 00:10 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (perl)


Attachments
patch to update the port (2.11 KB, patch)
2020-05-20 00:10 UTC, Sergei Vyshenski
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sergei Vyshenski 2020-05-20 00:10:08 UTC
Created attachment 214669 [details]
patch to update the port

- update 2.0204 -> 2.0205
Changes: https://metacpan.org/changes/distribution/XML-LibXML

- With release 2.0205, author of this module introduced 
a sort of cyclic dependencies: 
some submodules of this module are declared as "required" 
during build phase of this module.
(But in fact, they are not needed, and not employed.)
Hence, during build, the build dependency (textproc/p5-XML-SAX)
generates (as if) error messages like:
Can't locate perl module
*** Error (ignored)
Can't locate loadable object 
*** Error (ignored)
The author of textproc/p5-XML-LibXML cleverly ignores these "errors".
And after install, the module seems working properly.

- "portlint -AC" gives non-relevant warns.
- Tested with:
12.1-RELEASE-p5 amd64
poudriere 3.3.4
perl 5.30.2
pkg 1.14.4
- built-in perl tests in a clean poudriere jail say: PASS.