Bug 246590 - devel/py-rebulk: update to 2.0.1 (required by guessit >= 3.1)
Summary: devel/py-rebulk: update to 2.0.1 (required by guessit >= 3.1)
Status: Closed DUPLICATE of bug 246544
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-ports-bugs mailing list
URL: https://github.com/Toilal/rebulk/comp...
Keywords: patch
Depends on:
Blocks:
 
Reported: 2020-05-20 02:20 UTC by Jan Beich
Modified: 2020-05-20 02:22 UTC (History)
2 users (show)

See Also:


Attachments
v1 (1.27 KB, patch)
2020-05-20 02:20 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2020-05-20 02:20:40 UTC
Created attachment 214674 [details]
v1

Regressed by https://github.com/guessit-io/guessit/commit/a43966ab4154

$ flexget execute
Traceback (most recent call last):
  File "/usr/local/bin/flexget", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3251, in <module>
    @_call_aside
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3235, in _call_aside
    f(*args, **kwargs)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3264, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 585, in _build_master
    return cls._build_from_requirements(__requires__)
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 598, in _build_from_requirements
    dists = ws.resolve(reqs, Environment())
  File "/usr/local/lib/python2.7/site-packages/pkg_resources/__init__.py", line 791, in resolve
    raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (rebulk 0.9.0 (/usr/local/lib/python2.7/site-packages), Requirement.parse('rebulk==2.*'), set(['guessit']))
Comment 1 Jan Beich freebsd_committer 2020-05-20 02:21:36 UTC
Sorry, I forgot to look at the existing bugs.

*** This bug has been marked as a duplicate of bug 246544 ***