Bug 246634 - www/firefox: Fails to start after upgrade to 76.0.1_2,1
Summary: www/firefox: Fails to start after upgrade to 76.0.1_2,1
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: i386 Any
: --- Affects Only Me
Assignee: freebsd-gecko mailing list
URL:
Keywords: needs-qa, regression
Depends on:
Blocks:
 
Reported: 2020-05-21 13:40 UTC by chris
Modified: 2020-06-02 22:48 UTC (History)
0 users

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description chris 2020-05-21 13:40:04 UTC
firefox fails to start after upgrade to 76.0.1_2,1

Starting from console:

Script started on Thu May 21 14:09:55 2020
Command: firefox
1590066660927	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: mozillaAddons
1590066660928	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: telemetry
1590066660929	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: resource://pdf.js/
1590066660929	addons.webextension.screenshots@mozilla.org	WARN	Loading extension 'screenshots@mozilla.org': Reading manifest: Invalid extension permission: about:reader*
1590066661491	addons.webextension.doh-rollout@mozilla.org	WARN	Loading extension 'doh-rollout@mozilla.org': Reading manifest: Invalid extension permission: networkStatus
1590066662968	addons.xpi	WARN	Exception running bootstrap method update on default-theme@mozilla.org: TypeError: oldPermissions is null(resource://gre/modules/Extension.jsm:707:7) JS Stack trace: intersectPermissions@Extension.jsm:707:7
migratePermissions@Extension.jsm:735:34
update@Extension.jsm:1651:25
callBootstrapMethod@XPIProvider.jsm:1795:33
_install@XPIProvider.jsm:1970:18
update@XPIProvider.jsm:2078:17
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662970	addons.xpi	WARN	Exception running bootstrap method update on firefox-compact-light@mozilla.org: TypeError: oldPermissions is null(resource://gre/modules/Extension.jsm:707:7) JS Stack trace: intersectPermissions@Extension.jsm:707:7
migratePermissions@Extension.jsm:735:34
update@Extension.jsm:1651:25
callBootstrapMethod@XPIProvider.jsm:1795:33
_install@XPIProvider.jsm:1970:18
update@XPIProvider.jsm:2078:17
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662971	addons.xpi	WARN	Exception running bootstrap method update on firefox-compact-dark@mozilla.org: TypeError: oldPermissions is null(resource://gre/modules/Extension.jsm:707:7) JS Stack trace: intersectPermissions@Extension.jsm:707:7
migratePermissions@Extension.jsm:735:34
update@Extension.jsm:1651:25
callBootstrapMethod@XPIProvider.jsm:1795:33
_install@XPIProvider.jsm:1970:18
update@XPIProvider.jsm:2078:17
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662974	addons.xpi	WARN	Exception running bootstrap method update on google@search.mozilla.org: TypeError: oldOptionalPermissions is undefined(resource://gre/modules/Extension.jsm:750:1) JS Stack trace: migratePermissions@Extension.jsm:750:1
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662975	addons.xpi	WARN	Exception running bootstrap method update on amazon@search.mozilla.org: TypeError: oldOptionalPermissions is undefined(resource://gre/modules/Extension.jsm:750:1) JS Stack trace: migratePermissions@Extension.jsm:750:1
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662976	addons.xpi	WARN	Exception running bootstrap method update on bing@search.mozilla.org: TypeError: oldOptionalPermissions is undefined(resource://gre/modules/Extension.jsm:750:1) JS Stack trace: migratePermissions@Extension.jsm:750:1
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662977	addons.xpi	WARN	Exception running bootstrap method update on ddg@search.mozilla.org: TypeError: oldOptionalPermissions is undefined(resource://gre/modules/Extension.jsm:750:1) JS Stack trace: migratePermissions@Extension.jsm:750:1
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662978	addons.xpi	WARN	Exception running bootstrap method update on ebay@search.mozilla.org: TypeError: oldOptionalPermissions is undefined(resource://gre/modules/Extension.jsm:750:1) JS Stack trace: migratePermissions@Extension.jsm:750:1
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662979	addons.xpi	WARN	Exception running bootstrap method update on twitter@search.mozilla.org: TypeError: oldOptionalPermissions is undefined(resource://gre/modules/Extension.jsm:750:1) JS Stack trace: migratePermissions@Extension.jsm:750:1
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29
1590066662979	addons.xpi	WARN	Exception running bootstrap method update on wikipedia@search.mozilla.org: TypeError: oldOptionalPermissions is undefined(resource://gre/modules/Extension.jsm:750:1) JS Stack trace: migratePermissions@Extension.jsm:750:1
awaitPromise@XPIProvider.jsm:226:15
processFileChanges@XPIDatabase.jsm:3281:19
checkForChanges@XPIProvider.jsm:2955:55
startup@XPIProvider.jsm:2415:12
callProvider@AddonManager.jsm:215:31
_startProvider@AddonManager.jsm:587:17
startup@AddonManager.jsm:811:14
startup@AddonManager.jsm:3482:26
observe@addonManager.js:87:29

Command exit status: 12
Script done on Thu May 21 14:14:33 2020

Stack bt from coredump:

Script started on Thu May 21 14:16:46 2020
Command: lldb -c firefox.core
(lldb) target create --core "firefox.core"
Core file '/home/chris/firefox.core' (i386) was loaded.
(lldb) [1G[2m(lldb) [22m[8Gbt
* thread #1, name = 'SSL Cert #1', stop reason = signal SIGSYS
  * frame #0: 0x212626eb
    frame #1: 0x28315f88
Script done on Thu May 21 14:17:21 2020
Comment 1 Jan Beich freebsd_committer 2020-05-21 13:55:34 UTC
(In reply to chris from comment #0)
> * thread #1, name = 'SSL Cert #1', stop reason = signal SIGSYS

Are you using FreeBSD 13.0-CURRENT? If so upgrade kernel as binary packages are always built using the latest version.
Comment 2 chris 2020-05-22 09:26:50 UTC
(In reply to Jan Beich from comment #1)

Hi

I am running 12.1p5. My packages were from 12 ABI latest repository. I downgraded them last night to 12 quarterly, and firefox still coredumps with exactly the same results as given in my original report.

Thanks.
Comment 3 chris 2020-05-22 09:30:07 UTC
PS. The problem actually started after an upgrade to firefox 75, all was fine in 74 and previous.
Comment 4 chris 2020-05-31 10:34:29 UTC
I have upgraded to firefox 77.0 using FreeBSD 12 ABI package repository, with similar results to my original report. Running firefox from a shell gives:

Exiting due to channel error.
Exiting due to channel error.
Bad system call (core dumped)

[~]$ lldb -c firefox.core 
(lldb) target create --core "firefox.core"
Core file '/home/chris/firefox.core' (i386) was loaded.
(lldb) bt
* thread #1, name = 'SSL Cert #1', stop reason = signal SIGSYS
  * frame #0: 0x212626eb
    frame #1: 0x2847d818
Comment 5 Jan Beich freebsd_committer 2020-05-31 10:43:25 UTC
Maybe a duplicate of bug 243252.
Comment 6 chris 2020-05-31 11:50:46 UTC
Thanks for your reply Jan. The capability options are enabled in my kernel as per the bug you reference, so unfortunately this is not the answer.

I have deleted my .mozilla directory contents, and started afresh, just in case, although the problem remains.

Thanks

Chris