Bug 246684 - devel/fb-adb : remove dependency on expired lang/gnatdroid-armv7
Summary: devel/fb-adb : remove dependency on expired lang/gnatdroid-armv7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-23 19:49 UTC by Rene Ladan
Modified: 2020-05-24 09:26 UTC (History)
2 users (show)

See Also:


Attachments
remove dependency on expired gnatdroid-armv7, make NDK unconditional (3.65 KB, patch)
2020-05-23 19:49 UTC, Rene Ladan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rene Ladan freebsd_committer 2020-05-23 19:49:34 UTC
Created attachment 214792 [details]
remove dependency on expired gnatdroid-armv7, make NDK unconditional

This patch attempts to remove the dependency of fb-adb on the expired gnatdroid-armv7. It does not patch yet for some reason, likely because I tried to make the NDK option unconditional (since switching it off no longer made sense).

The Makefile has been simplified and restructured a lot.
Comment 1 commit-hook freebsd_committer 2020-05-24 09:25:29 UTC
A commit references this bug:

Author: jbeich
Date: Sun May 24 09:25:14 UTC 2020
New revision: 536371
URL: https://svnweb.freebsd.org/changeset/ports/536371

Log:
  devel/fb-adb: drop non-NDK support

  lang/gnatdroid-armv7 has expired and is about to be removed.

  PR:		246684
  Submitted by:	rene

Changes:
  head/devel/fb-adb/Makefile