Bug 246687 - www/firefox tab crashes on some sites with their own fonts
Summary: www/firefox tab crashes on some sites with their own fonts
Status: Closed DUPLICATE of bug 245915
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gecko mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-23 23:09 UTC by Patrick Mackinlay
Modified: 2020-05-24 10:36 UTC (History)
0 users

See Also:
bugzilla: maintainer-feedback? (gecko)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Mackinlay 2020-05-23 23:09:56 UTC
If firefox is configured to allow pages to choose their own fonts and you visit a uk government website (https://www.gov.uk/) the tab crashes.

If you configure firefox to disallow pages to choose their own fonts the tab works fine. 

This has been happening for some time (at least 3 months, but possibly much longer). I just tried this with firefox-76.0_3,1 on FreeBSD 12.1 amd64 and with a brand new profile.

Note that with firefox for OS X this doesn't happen, so the issue appears to be specific to FreeBSD.

I am a very heavy user of firefox on FreeBSD and this only ever seems to happen for uk government websites, they seem to provide their own fonts.
Comment 1 Jan Beich freebsd_committer 2020-05-24 00:38:40 UTC
Duplicate of bug 245915?
Comment 2 Patrick Mackinlay 2020-05-24 10:36:37 UTC
Yes, upgrading to fontconfig-2.13.92_2,1 fixed the problem.

thanks very much for your help.

*** This bug has been marked as a duplicate of bug 245915 ***