Bug 246716 - www/py-django-hijack: Switch to Django 2.2 and fix missing dependency
Summary: www/py-django-hijack: Switch to Django 2.2 and fix missing dependency
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kai Knoblich
URL:
Keywords:
Depends on:
Blocks: 245309
  Show dependency treegraph
 
Reported: 2020-05-25 07:39 UTC by Kai Knoblich
Modified: 2020-05-25 11:47 UTC (History)
1 user (show)

See Also:
ports: maintainer-feedback+


Attachments
py-django-hijack-django22-fix-missing-dependency.patch (4.03 KB, patch)
2020-05-25 07:39 UTC, Kai Knoblich
ports: maintainer-approval+
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Kai Knoblich freebsd_committer 2020-05-25 07:39:01 UTC
Created attachment 214836 [details]
py-django-hijack-django22-fix-missing-dependency.patch

Hi,

attached is the patch that switches www/py-django-hijack to Django 2.2 (current LTS release) because Django 1.11 is End-of-Life.

It also adds www/py-django-compat which is required by www/py-django-hijack for runtime:

>  File "/usr/local/lib/python3.7/site-packages/hijack/apps.py", line 10, in ready
>    from hijack.checks import register_checks
>  File "/usr/local/lib/python3.7/site-packages/hijack/checks.py", line 6, in <module>
>    from compat import import_string
> ModuleNotFoundError: No module named 'compat'

Changes to the port:
~~~~~~~~~~~~~~~~~~~~
* Fix a typo in the COMMENT field

QA:
~~~
- poudriere (11.3-RELEASE amd64 for each py35, py36, py37 and py38 flavor) -> OK
- portlint -> OK
Comment 1 commit-hook freebsd_committer 2020-05-25 11:41:16 UTC
A commit references this bug:

Author: kai
Date: Mon May 25 11:40:24 UTC 2020
New revision: 536460
URL: https://svnweb.freebsd.org/changeset/ports/536460

Log:
  [NEW PORT] www/py-django-compat

  Forward and backwards compatibility layer for different Django versions.

  Reasons to use django-compat:

  * Be able to use LTS versions of Django and support newer versions in an app
  * Use features from newer Django versions in an old one
  * Manage and master the gap between different framework versions

  WWW: https://github.com/arteria/django-compat

  PR:		246716

Changes:
  head/www/Makefile
  head/www/py-django-compat/
  head/www/py-django-compat/Makefile
  head/www/py-django-compat/distinfo
  head/www/py-django-compat/pkg-descr
Comment 2 commit-hook freebsd_committer 2020-05-25 11:44:18 UTC
A commit references this bug:

Author: kai
Date: Mon May 25 11:44:11 UTC 2020
New revision: 536462
URL: https://svnweb.freebsd.org/changeset/ports/536462

Log:
  www/py-django-hijack: Change/Fix RUN_DEPENDS

  * Switch the port to Django 2.2 (current LTS release) because Django 1.11 is
    End-of-Life since April.

  * Fix a typo in the COMMENT field and bump PORTREVISION due changed
    dependencies.

  PR:		246716
  Approved by:	Kevin Golding <ports@caomhin.org> (maintainer)

Changes:
  head/www/py-django-hijack/Makefile
Comment 3 Kai Knoblich freebsd_committer 2020-05-25 11:47:22 UTC
Committed, thank you for the quick approval!