Bug 246773 - sysutils/py-diffoscope: Update to 147
Summary: sysutils/py-diffoscope: Update to 147
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: Kubilay Kocak
URL: https://lists.reproducible-builds.org...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-27 10:43 UTC by Fabian Keil
Modified: 2020-06-16 06:02 UTC (History)
0 users

See Also:
koobs: maintainer-feedback+


Attachments
sysutils/py-diffoscope: Update to 145 (1.35 KB, patch)
2020-05-27 10:43 UTC, Fabian Keil
no flags Details | Diff
sysutils/py-diffoscope: Update to 146 (1.47 KB, patch)
2020-06-07 12:47 UTC, Fabian Keil
no flags Details | Diff
sysutils/py-diffoscope: Update to 147 (2.50 KB, patch)
2020-06-15 12:03 UTC, Fabian Keil
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Fabian Keil 2020-05-27 10:43:10 UTC
Created attachment 214907 [details]
sysutils/py-diffoscope: Update to 145

The attached patch updates sysutils/py-diffoscope to 145.

The change log is available at:
https://lists.reproducible-builds.org/pipermail/rb-general/2020-May/001947.html
Comment 1 Fabian Keil 2020-06-07 12:47:15 UTC
Created attachment 215316 [details]
sysutils/py-diffoscope: Update to 146
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-10 05:37:33 UTC
Thanks for the report and patch Fabian

I'm seeing a ton of errors during make test (platform freebsd13 -- Python 3.8.3, pytest-4.5.0, py-1.8.1, pluggy-0.12.0), mostly of type:

  Fuzzy-matching is currently disabled as the "tlsh" module is unavailable

Should these be skipped (other tests skip correctly when needed features arent available)?

Is there a TEST_DEPENDS we can add to cover the functionality?

Also seeing quite a few of the following:

   IndexError: list index out of range

Is diffoscope supposed to currently support 3.8?
Comment 3 Fabian Keil 2020-06-10 10:17:14 UTC
I must admit that I only tested with poudriere testport ...

I'm also getting "a ton of errors" when running the tests and have reported the issue to the upstream mailing list:
https://lists.reproducible-builds.org/pipermail/diffoscope/2020-June/002642.html

The annoying no-tlsh-module warning has been added a while ago so I suspect that the test failures aren't new either.

"tlsh" hasn't been ported to FreeBSD yet, so unfortunately this isn't as simple as extending TEST_DEPENDS.

I'm also getting "list index out of range" errors with Python 3.7.7 so this doesn't seem to be a Python 3.8 issue.
Comment 4 Fabian Keil 2020-06-15 12:03:16 UTC
Created attachment 215580 [details]
sysutils/py-diffoscope: Update to 147

This patch updates sysutils/py-diffoscope to the recently released version 147.

It includes a patch from Mattia Rizzolo to prevent tests from failing due to the no-tlsh-module warning.

There are still a couple of failing tests left (19 on my system), but as the test failures aren't new I don't think they should block the update.

The change logs for 145, 146 and 147 are available at:
https://lists.reproducible-builds.org/pipermail/rb-general/2020-May/001947.html
https://lists.reproducible-builds.org/pipermail/rb-general/2020-May/001948.html
https://lists.reproducible-builds.org/pipermail/rb-general/2020-June/001964.html
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-15 12:52:19 UTC
(In reply to Fabian Keil from comment #4)

Much love Fabian, thank you for taking care of these issues with upstream
Comment 6 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-16 05:40:25 UTC
20 failed, 280 passed, 144 skipped in 766.30 seconds on last QA run

Much better. Should look into porting tlsh (doesn't look too hard?)
Comment 7 commit-hook freebsd_committer 2020-06-16 06:01:57 UTC
A commit references this bug:

Author: koobs
Date: Tue Jun 16 06:01:26 UTC 2020
New revision: 539325
URL: https://svnweb.freebsd.org/changeset/ports/539325

Log:
  sysutils/py-diffoscope: Update to 147

   - Add upstream [1] patch to prevent tlsh dependent tests from failing

  Changelog:

  145: https://lists.reproducible-builds.org/pipermail/rb-general/2020-May/001947.html
  146: https://lists.reproducible-builds.org/pipermail/rb-general/2020-May/001948.html
  147: https://lists.reproducible-builds.org/pipermail/rb-general/2020-June/001964.html

  [1] https://lists.reproducible-builds.org/pipermail/diffoscope/2020-June/002642.html

  PR:		246773
  Submitted by:	Fabian Keil <fk fabiankeil de>
  MFH:		No (combined feature/bugfix releases)

Changes:
  head/sysutils/py-diffoscope/Makefile
  head/sysutils/py-diffoscope/distinfo
  head/sysutils/py-diffoscope/files/
  head/sysutils/py-diffoscope/files/patch-diffoscope_main.py
Comment 8 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-16 06:02:20 UTC
Committed, thank you Fabian!