Bug 246810 - graphics/cairo still depends on expiring python 2.7 via graphics/mesa-libs
Summary: graphics/cairo still depends on expiring python 2.7 via graphics/mesa-libs
Status: Closed DUPLICATE of bug 239939
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-28 16:08 UTC by Vincent Bentley
Modified: 2020-06-26 20:17 UTC (History)
1 user (show)

See Also:
jbeich: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vincent Bentley 2020-05-28 16:08:10 UTC
graphics/cairo 1.16.0 has a dependency on graphics/mesa-libs 19.0.8 which has a dependency on Python 2.7 . Python 2.7 has already reached End of Life upstream. Consequently, the mesa-libs port has been marked deprecated and is scheduled to expire on 31 December 2020. If not fixed, the removal of graphics/mesa-libs is likely to affect this port in 2021.
Comment 1 Ting-Wei Lan 2020-05-30 15:03:30 UTC
(In reply to Vincent Bentley from comment #0)
Shouldn't the issue be handled by mesa-libs maintainer? Mesa is essential to a desktop system, so I don't think mesa-libs maintainer will ignore the issue.
Comment 2 Jan Beich freebsd_committer 2020-06-26 20:17:11 UTC
Nothing gnome@ can do here short of disabling OPENGL option.

*** This bug has been marked as a duplicate of bug 239939 ***