Bug 246828 - dns/powerdns: cannot install: unknown MySQL version: 8.
Summary: dns/powerdns: cannot install: unknown MySQL version: 8.
Status: Closed Not A Bug
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-05-29 08:51 UTC by Ulas SAYGIN
Modified: 2020-06-29 12:09 UTC (History)
2 users (show)

See Also:
tremere: maintainer-feedback+


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulas SAYGIN 2020-05-29 08:51:38 UTC
i cant install powerdns with mysql 8.
I think it needs upgrade or patch.


FreeBSD 12.1-RELEASE FreeBSD 12.1-RELEASE r354233 GENERIC  amd64

my make.conf and src.conf below.

/etc/make.conf
# allow compiler optimizations specific to our CPU model
CPUTYPE?=haswell
CFLAGS=-O2 -pipe -fno-strict-aliasing
COPTFLAGS=-O2 -pipe -funroll-loops -ffast-math -fno-strict-aliasing

# disable profiling, unless you like 1hr compile times
MK_PROFILE=no

#WITH_CCACHE_BUILD=yes
#CCACHE_DIR=/tmp/ccache



#Default Versions

DEFAULT_VERSIONS+=ssl=libressl python=3.8 python2=2.7 python3=3.8 php=7.4 pgsql=12 mysql=8

# Headless server options
OPTIONS_SET+=ICONV OPTIMIZED_CFLAGS CPUFLAGS OPTIMIZED
OPTIONS_UNSET+=CUPS DEBUG DOCS FONTCONFIG NLS X11 MAN EXAMPLES MAN3 MANPAGES DTRACE GITWEB
## Libre SSL Needs These
ftp_curl_UNSET=   TLS_SRP
# LibreSSL doesn't work with GSSAPI_BASE
security_p5-GSSAPI_SET     = GSSAPI_MIT
OPTIONS_UNSET             += GSSAPI_BASE


 /etc/src.conf
WITHOUT_ACCT=YES
WITHOUT_AMD=YES
WITHOUT_ATM=YES
WITHOUT_AUDIT=YES
WITHOUT_AUTHPF=YES
WITHOUT_AUTOFS=YES
WITHOUT_BHYVE=YES
WITHOUT_BLUETOOTH=YES
WITHOUT_BOOTPARAMD=YES
WITHOUT_BOOTPD=YES
WITHOUT_BSNMP=YES
WITHOUT_CALENDAR=YES
WITHOUT_CAPSICUM=YES
WITHOUT_CASPER=YES
WITHOUT_CCD=YES

WITHOUT_CTM=YES
WITHOUT_CUSE=YES
WITHOUT_CXGBETOOL=YES

WITHOUT_DEBUG_FILES=YES
WITHOUT_DICT=YES

WITHOUT_DMAGENT=YES


WITHOUT_ED_CRYPTO=YES

WITHOUT_EXAMPLES=YES

WITHOUT_FDT=YES

WITHOUT_FINGER=YES
WITHOUT_FLOPPY=YES

WITHOUT_FTP=YES
WITHOUT_GAMES=YES


WITHOUT_GCOV=YES
WITHOUT_GDB=YES
WITHOUT_GPIO=YES

WITHOUT_GSSAPI=YES
WITHOUT_HAST=YES
WITHOUT_HTML=YES
WITHOUT_HYPERV=YES

WITHOUT_IPFILTER=YES

WITHOUT_ISCSI=YES
WITHOUT_JAIL=YES

WITHOUT_KDUMP=YES

WITHOUT_KERBEROS=YES
WITHOUT_KERBEROS_SUPPORT=YES

WITHOUT_KERNEL_SYMBOLS=YES
WITHOUT_KVM=YES


# WITHOUT_LEGACY_CONSOLE=YES
WITHOUT_LLDB=YES
WITH_LLD_IS_LD=yes
WITH_LLD_BOOTSTRAP=yes


WITHOUT_LLVM_TARGET_AARCH64=YES
WITHOUT_LLVM_TARGET_ARM=YES
WITHOUT_LLVM_TARGET_MIPS=YES
WITHOUT_LLVM_TARGET_POWERPC=YES
WITHOUT_LLVM_TARGET_SPARC=YES

WITHOUT_LPR=YES
WITHOUT_MAILWRAPPER=YES

WITHOUT_MAN=YES
WITHOUT_MAN_UTILS=YES 

WITHOUT_MLX5TOOL=YES 
WITHOUT_MODULE_DRM=YES
WITHOUT_MODULE_DRM2=YES

WITHOUT_NDIS=YES
WITHOUT_NETGRAPH=YES

WITHOUT_NIS=YES
WITHOUT_NLS=YES
WITHOUT_NTP=YES

WITHOUT_OPENSSH=YES

WITHOUT_PF=YES
WITHOUT_PMC=YES
WITHOUT_PPP=YES
WITHOUT_PROFILE=YES

WITHOUT_QUOTAS=YES

WITHOUT_RADIUS_SUPPORT=YES

WITHOUT_RBOOTD=YES
WITHOUT_RESCUE=YES
WITHOUT_ROUTED=YES 
WITHOUT_SENDMAIL=YES
WITHOUT_SHAREDOCS=YES
WITHOUT_SSP=YES

WITHOUT_TALK=YES
WITHOUT_TCP_WRAPPERS=YES

WITHOUT_TFTP=YES
WITHOUT_TIMED=YES
WITHOUT_USB=YES
WITHOUT_VI=YES
WITHOUT_WIRELESS=YES
WITHOUT_WPA_SUPPLICANT_EAPOL=YES
Comment 1 Ralf van der Enden 2020-06-17 07:35:13 UTC
Hi,

Can you provide a buildlog? That way I can investigate where things go wrong.

Thanks in advance.
Comment 2 Ralf van der Enden 2020-06-17 09:20:00 UTC
This is an easy fix. The error about myql is caused by an invalid number in the DEFAULT_VERSIONS variable.

To make use of MySQL 8 you need to use mysql=8.0 and not mysql=8.

Once you've made that change it should build fine.
Comment 3 Kubilay Kocak freebsd_committer freebsd_triage 2020-06-29 12:09:32 UTC
Thanks Ralph!