Bug 246988 - lang/ghc: requires llvm70 for ghc 8.8
Summary: lang/ghc: requires llvm70 for ghc 8.8
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: arm Any
: --- Affects Only Me
Assignee: freebsd-haskell (Nobody)
URL: http://thunderx1.nyi.freebsd.org/data...
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-04 18:07 UTC by Mikael Urankar
Modified: 2020-06-04 19:32 UTC (History)
1 user (show)

See Also:
bugzilla: maintainer-feedback? (haskell)


Attachments
patch (730 bytes, patch)
2020-06-04 18:07 UTC, Mikael Urankar
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Mikael Urankar freebsd_committer 2020-06-04 18:07:17 UTC
Created attachment 215233 [details]
patch

untested

You are using an unsupported version of LLVM!
Currently only 7 is supported. System LLVM version: 6.0.1
We will try though...
Comment 1 commit-hook freebsd_committer 2020-06-04 19:31:51 UTC
A commit references this bug:

Author: arrowd
Date: Thu Jun  4 19:31:42 UTC 2020
New revision: 537934
URL: https://svnweb.freebsd.org/changeset/ports/537934

Log:
  lang/ghc: Depend on newer LLVM 7.0, for which upstream declares support.

  PR:		246988
  Submitted by:	mikael

Changes:
  head/lang/ghc/Makefile
Comment 2 Gleb Popov freebsd_committer 2020-06-04 19:32:54 UTC
Yep, overlooked that. Thanks!