Bug 247026 - graphics/mesa-dri: build fails, apparently due the the presence of llvm-devel
Summary: graphics/mesa-dri: build fails, apparently due the the presence of llvm-devel
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-06 10:24 UTC by Philippe Michel
Modified: 2020-06-08 10:42 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
portmaster log (873.33 KB, text/plain)
2020-06-06 10:24 UTC, Philippe Michel
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe Michel 2020-06-06 10:24:58 UTC
Created attachment 215289 [details]
portmaster log

Build of mesa-dri-19.0.8_2 fails (see attached log), apparently due to the presence of llvm-devel.

I didn't try to uninstall this package to check, but the:
llvm-config found: YES (/usr/local/bin/llvm-config-devel) 11.0.0
while building the port without specifically trying to use this version of the compiler doesn't look right.

This is a recent regression. Build of mesa-dri-19.0.8 about a month ago when I already had llvm-devel installed went fine.
Comment 1 freebsd-bugs 2020-06-08 00:23:41 UTC
Affects me too. Removing llvm-devel allows build.
Comment 2 commit-hook freebsd_committer 2020-06-08 09:56:37 UTC
A commit references this bug:

Author: manu
Date: Mon Jun  8 09:55:39 UTC 2020
New revision: 538207
URL: https://svnweb.freebsd.org/changeset/ports/538207

Log:
  mesa*: Switch to using a native-file for llvm

  Meson seems to not care that a llvm-config binary exists and will prefer
  to use llvm-config-devel for some reason.
  Using a native-file fixes that and meson will correctly use the llvm specified
  in it.

  PR:	247026
  Approved by:	zeising (x11@ implicit)

Changes:
  head/graphics/mesa-dri/Makefile.common
  head/graphics/mesa-dri/Makefile.targets
Comment 3 Emmanuel Vadot freebsd_committer 2020-06-08 10:42:01 UTC
Fixed,
Thanks for the report.