Bug 247059 - accessibility/speech-dispatcher: update to 0.10.2
Summary: accessibility/speech-dispatcher: update to 0.10.2
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Thomas Zander
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-07 19:33 UTC by Greg V
Modified: 2021-05-01 11:33 UTC (History)
3 users (show)

See Also:
riggs: maintainer-feedback+


Attachments
speech-dispatcher.patch (9.12 KB, patch)
2020-06-07 19:33 UTC, Greg V
no flags Details | Diff
speech-dispatcher.patch v2 (9.20 KB, patch)
2020-07-08 11:51 UTC, Greg V
no flags Details | Diff
speech-dispatcher.patch v3 (11.14 KB, patch)
2020-07-09 11:43 UTC, Greg V
no flags Details | Diff
speech-dispatcher.patch v4 (9.36 KB, patch)
2020-07-21 19:51 UTC, Greg V
no flags Details | Diff
Update to 0.10.2 (17.19 KB, patch)
2021-04-23 17:32 UTC, Thomas Zander
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Greg V 2020-06-07 19:33:16 UTC
Created attachment 215329 [details]
speech-dispatcher.patch

This project now lives on github: https://github.com/brailcom/speechd
Comment 1 Peter Laursen 2020-06-24 05:27:44 UTC
Hi,
Since you are about to update Speech Dispatcher to the latest version, could I suggest we add AO to the list of default options?
On virtual machines in particular, the audio produced by speech dispatcher is choppy when using the OSS support in speech dispatcher; adding AO to the default options fixes that problem.

Thanks for reading,

Peter.
Comment 2 Greg V 2020-07-08 11:51:12 UTC
Created attachment 216319 [details]
speech-dispatcher.patch v2

(In reply to Peter Laursen from comment #1)
hm. Would PulseAudio work for you?
Comment 3 Peter Laursen 2020-07-08 12:20:58 UTC
Hi,
Pulseaudio also works.
Comment 4 Greg V 2020-07-09 11:43:45 UTC
Created attachment 216337 [details]
speech-dispatcher.patch v3
Comment 5 Greg V 2020-07-21 19:51:42 UTC
Created attachment 216639 [details]
speech-dispatcher.patch v4

aaaand we should use the release tarball which has the .tarball-version so that the header generates correctly.
Comment 6 Peter Laursen 2020-12-22 05:37:20 UTC
Hi,
Any news regarding the update?
If we don't plan on updating the current port, could we add Pulseaudio to the default options to fix the audio stuttering I hinted at in one of the above comments?

Thank you,

Peter.
Comment 7 Rainer Hurling freebsd_committer 2020-12-22 07:54:26 UTC
An update to 10.2 released four weeks ago, version 10.1 in August:

https://github.com/brailcom/speechd/releases/tag/0.10.2
https://github.com/brailcom/speechd/releases/tag/0.10.1


It seems, there was some rework on the audio device ...
Comment 8 Thomas Zander freebsd_committer 2021-04-23 17:32:12 UTC
Created attachment 224384 [details]
Update to 0.10.2
Comment 9 Thomas Zander freebsd_committer 2021-04-23 17:33:41 UTC
(In reply to Thomas Zander from comment #8)

Can someone who uses this regularly (Greg? Peter?) check whether this update works as intended.
Please also try without the pulseaudio option. If the choppy audio is resolved, I would like to avoid adding another default dependency.
Comment 10 Greg V 2021-04-26 11:38:59 UTC
Does work for me.

I wasn't having issues without pulse, I just use pulse for all audio ever to get control over it (mixing, live switching to hotplugged devices etc.)
Comment 11 commit-hook freebsd_committer 2021-05-01 07:37:57 UTC
A commit in branch main references this bug:

URL: https://cgit.FreeBSD.org/ports/commit/?id=752be38ce2a85c213bc36cd962ce9e90840a9353

commit 752be38ce2a85c213bc36cd962ce9e90840a9353
Author:     Thomas Zander <riggs@FreeBSD.org>
AuthorDate: 2021-05-01 06:16:01 +0000
Commit:     Thomas Zander <riggs@FreeBSD.org>
CommitDate: 2021-05-01 07:37:14 +0000

    accessibility/speech-dispatcher: update to 0.10.2.

    PR:             247059
    Reported by:    greg@unrelenting.technology

 accessibility/speech-dispatcher/Makefile           |  30 +-
 accessibility/speech-dispatcher/distinfo           |   6 +-
 .../files/patch-src_Makefile.in (gone)             |  11 -
 accessibility/speech-dispatcher/pkg-plist          | 329 ++++++++++++++++++++-
 4 files changed, 346 insertions(+), 30 deletions(-)