Bug 247067 - x11-toolkits/gtk30: update to 3.24.20
Summary: x11-toolkits/gtk30: update to 3.24.20
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Jan Beich
URL: https://gitlab.gnome.org/GNOME/gtk/co...
Keywords: patch
Depends on: 239026
Blocks: 249288
  Show dependency treegraph
 
Reported: 2020-06-07 20:42 UTC by Jan Beich
Modified: 2020-09-13 07:02 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (gnome)
antoine: exp-run+


Attachments
v1 (15.12 KB, patch)
2020-06-07 20:42 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2020-06-07 20:42:07 UTC
As updating devel/glib20 opens a pandemonium let's revert a few changes.
Tested via www/firefox on X11 and Wayland.
Comment 1 Jan Beich freebsd_committer 2020-06-07 20:42:58 UTC
Created attachment 215338 [details]
v1
Comment 2 Charlie Li 2020-06-07 23:53:13 UTC
I have 3.24.18 in the gnome@ devel repo, which also includes devel/glib20 update to 2.64. Been dogfooding this combination for over a month now. The glib update is not only necessary to update GNOME eventually, but certain other non-GNOME software in ports also need newer glib, namely MATE.

https://github.com/freebsd/freebsd-ports-gnome/pull/37
Comment 3 Jan Beich freebsd_committer 2020-06-08 06:46:43 UTC
Glib update requires skipping several minor versions and touches platform-specific code. In case of regressions fixes maybe non-trivial.
Gtk update lacks both risks. I don't use Gnome or any other DE, so my motivation is to get bug fixes and Wayland improvements.

(In reply to Charlie Li from comment #2)
> certain other non-GNOME software in ports also need newer glib

Even one of my ports, see x11/wofi/files/patch-glib-2.56.
Comment 4 Jan Beich freebsd_committer 2020-06-08 06:56:59 UTC
Also, Glib update requires switching to Meson because upstream stopped generating configure, config.h.in, Makefile.in, etc. since 2.57 then removed autotools support in 2.59.
Comment 5 Antoine Brodin freebsd_committer 2020-06-16 08:00:55 UTC
Exp-run looks fine
Comment 6 commit-hook freebsd_committer 2020-06-18 00:57:06 UTC
A commit references this bug:

Author: jbeich
Date: Thu Jun 18 00:56:16 UTC 2020
New revision: 539511
URL: https://svnweb.freebsd.org/changeset/ports/539511

Log:
  x11-toolkits/gtk30: update to 3.24.20

  Changes:	https://gitlab.gnome.org/GNOME/gtk/compare/3.24.10...3.24.20
  PR:		247067
  Exp-run by:	antoine

Changes:
  head/x11-toolkits/gtk30/Makefile
  head/x11-toolkits/gtk30/distinfo
  head/x11-toolkits/gtk30/files/patch-glib-2.56
  head/x11-toolkits/gtk30/pkg-plist