Bug 247080 - databases/postgresql12-server: CURRENT: LLVM ERROR: ThinLink didn't create an index
Summary: databases/postgresql12-server: CURRENT: LLVM ERROR: ThinLink didn't create an...
Status: Closed DUPLICATE of bug 244403
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: pgsql
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-08 09:47 UTC by O. Hartmann
Modified: 2020-09-26 05:42 UTC (History)
4 users (show)

See Also:
bugzilla: maintainer-feedback? (pgsql)


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description O. Hartmann 2020-06-08 09:47:00 UTC
Environment: poudriere pkg build system, host running CURRENT (FreeBSD 13.0-CURRENT #12 r361830: Fri Jun  5 10:51:20 CEST 2020 amd64), jail is CURRENT:

=>> Building databases/postgresql12-server
build started at Mon Jun  8 09:30:14 UTC 2020
port directory: /usr/ports/databases/postgresql12-server
package name: postgresql12-server-12.3
building for: FreeBSD host.name.gdr 13.0-CURRENT FreeBSD 13.0-CURRENT 1300097 amd64
maintained by: pgsql@FreeBSD.org
Makefile ident:      $FreeBSD: head/databases/postgresql12-server/Makefile 535676 2020-05-17 20:37:04Z girgen $
Poudriere version: 3.3.4
Host OSVERSION: 1300097
Jail OSVERSION: 1300097
Job Id: 01

---Begin Environment---
SHELL=/bin/csh
OSVERSION=1300097
UNAME_v=FreeBSD 13.0-CURRENT 1300097
UNAME_r=13.0-CURRENT
BLOCKSIZE=K
MAIL=/var/mail/root
STATUS=1
HOME=/root
PATH=/sbin:/bin:/usr/sbin:/usr/bin:/usr/local/sbin:/usr/local/bin:/root/bin
LOCALBASE=/usr/local
USER=root
LIBEXECPREFIX=/usr/local/libexec/poudriere
POUDRIERE_VERSION=3.3.4
MAKEOBJDIRPREFIX=/pool/sources/CURRENT/obj/
MASTERMNT=/pool/poudriere/data/.m/headamd64-head-default/ref
POUDRIERE_BUILD_TYPE=bulk
PACKAGE_BUILDING=yes
SAVED_TERM=xterm
PWD=/pool/poudriere/data/.m/headamd64-head-default/ref/.p/pool
P_PORTS_FEATURES=FLAVORS SELECTED_OPTIONS
MASTERNAME=headamd64-head-default
SCRIPTPREFIX=/usr/local/share/poudriere
OLDPWD=/pool/poudriere/data/.m/headamd64-head-default/ref/.p
SCRIPTPATH=/usr/local/share/poudriere/bulk.sh
POUDRIEREPATH=/usr/local/bin/poudriere
---End Environment---

---Begin Poudriere Port Flags/Env---
PORT_FLAGS=
PKGENV=
FLAVOR=
DEPENDS_ARGS=
MAKE_ARGS=
---End Poudriere Port Flags/Env---

---Begin OPTIONS List---
===> The following configuration options are available for postgresql12-server-12.3:
     DEBUG=off: Build with debugging support
     DOCS=on: Build and/or install documentation
     DTRACE=off: Build with DTrace probes
     GSSAPI=on: Build with GSSAPI support
     INTDATE=on: Builds with 64-bit date/time type
     LDAP=on: Build with LDAP authentication support
     LLVM=on: Build with support for JIT-compiling expressions
     NLS=on: Use internationalized messages
     OPTIMIZED_CFLAGS=on: Builds with compiler optimizations (-O3)
     PAM=on: Build with PAM Support
     SSL=on: Build with OpenSSL support
     TZDATA=on: Use internal timezone database
     XML=on: Build with XML data type
===> Use 'make config' to modify these settings
---End OPTIONS List---
[...]

Port build of databases/postgresql12-server fails on the following error:


[...]
error: can't create module summary index for buffer: Invalid summary version 8. Version should be in the range [1-7].
LLVM ERROR: ThinLink didn't create an index
gmake[1]: *** [Makefile:219: install-postgres-bitcode] Error 1
gmake[1]: Leaving directory '/wrkdirs/usr/ports/databases/postgresql12-server/work/postgresql-12.3/src/backend'
gmake: *** [../../src/Makefile.global:819: install-strip] Error 2
*** Error code 2

Stop.
make: stopped in /usr/ports/databases/postgresql12-server
=>> Cleaning up wrkdir
===>  Cleaning for postgresql12-server-12.3
build of databases/postgresql12-server | postgresql12-server-12.3 ended at Mon Jun  8 09:37:38 UTC 2020
build time: 00:07:24
!!! build failure encountered !!!
[...]
Comment 1 Volodymyr Kostyrko 2020-06-25 21:32:21 UTC
Same happens when building on STABLE after upgrade to clang10.
Comment 3 O. Hartmann 2020-09-26 05:42:26 UTC

*** This bug has been marked as a duplicate of bug 244403 ***