Bug 247117 - graphics/mesa-dri: fails to build on armv6/armv7
Summary: graphics/mesa-dri: fails to build on armv6/armv7
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: freebsd-x11 (Nobody)
URL:
Keywords: buildisok, patch, regression
Depends on:
Blocks:
 
Reported: 2020-06-09 16:29 UTC by Jan Beich
Modified: 2020-07-11 14:39 UTC (History)
2 users (show)

See Also:
bugzilla: maintainer-feedback? (x11)


Attachments
fix (1.48 KB, patch)
2020-06-09 16:29 UTC, Jan Beich
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Beich freebsd_committer 2020-06-09 16:29:42 UTC
Created attachment 215398 [details]
fix

Regressed by ports r537998. Only swrast is supported armv[67], mips*, riscv64, sparc64. Of those sparc64 passes -Dllvm=false, so it cannot use swrast from Gallium.

$ make
make: "/usr/ports/graphics/mesa-dri/Makefile" line 106: Malformed conditional (${DRI_DRIVERS:M${:UI915}})
make: "/usr/ports/graphics/mesa-dri/Makefile" line 106: Malformed conditional (${DRI_DRIVERS:M${:UI965}})
make: "/usr/ports/graphics/mesa-dri/Makefile" line 106: Malformed conditional (${DRI_DRIVERS:M${:UR100}})
make: "/usr/ports/graphics/mesa-dri/Makefile" line 106: Malformed conditional (${DRI_DRIVERS:M${:UR200}})
make: "/usr/ports/graphics/mesa-dri/Makefile" line 106: Malformed conditional (${DRI_DRIVERS:M${:USWRAST}})
make: Fatal errors encountered -- cannot continue
make: stopped in /usr/ports/graphics/mesa-dri
Comment 1 Jan Beich freebsd_committer 2020-06-09 16:32:13 UTC
Comment on attachment 215398 [details]
fix

Oops, incomplete fix:

  meson.build:207:2: ERROR: Problem encountered: Only one swrast provider can be built
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2020-06-09 17:11:53 UTC
Cc: committer of r537998 .
Comment 3 commit-hook freebsd_committer 2020-06-09 19:56:51 UTC
A commit references this bug:

Author: zeising
Date: Tue Jun  9 19:56:17 UTC 2020
New revision: 538339
URL: https://svnweb.freebsd.org/changeset/ports/538339

Log:
  mesa: Fix build empty DRI_DRIVER

  In some cases, such as on sparc64, armv6 and armv7 etc, DRI_DRIVER,
  GALLIUM_DRIVER and/or VULKAN_DRIVER might be undefined.  This causes an
  error similar to
  make: "/usr/ports/graphics/mesa-dri/Makefile" line 106: Malformed conditional (${DRI_DRIVERS:M${:UI915}})

  Fix this by checking if [DRI,GALLIUM,VULKAN]_DRIVER is defined before
  checking what it is set to.

  While here, remove textproc/py-mako dependency from mesa-dri/Makefile, it's
  already included in mesa-dri/Makefile.common, no need to depend on it twice.

  PR:		247117
  Reported by:	jbeich

Changes:
  head/graphics/mesa-dri/Makefile
  head/graphics/mesa-libs/Makefile
Comment 4 Niclas Zeising freebsd_committer 2020-06-09 19:57:42 UTC
Should be fixed now, thanks for the report.
Comment 5 Jan Beich freebsd_committer 2020-06-09 20:05:21 UTC
Still fails here:

$ make install
[...]
===>   Registering installation for mesa-dri-19.0.8_4
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/mesa-dri/work/stage/usr/local/include/GL/internal/dri_interface.h:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/mesa-dri/work/stage/usr/local/lib/dri/kms_swrast_dri.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/mesa-dri/work/stage/usr/local/lib/dri/swrast_dri.so:No such file or directory
pkg-static: Unable to access file /wrkdirs/usr/ports/graphics/mesa-dri/work/stage/usr/local/libdata/pkgconfig/dri.pc:No such file or directory
*** Error code 74
Comment 6 Niclas Zeising freebsd_committer 2020-06-09 20:12:06 UTC
Reopen this since it's apparently not fixed.

I'll have to take a closer look tomorrow at what's going on.
Comment 7 Automation User 2020-06-24 00:59:37 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/159425167
Comment 8 Niclas Zeising freebsd_committer 2020-07-11 14:39:54 UTC
I believe this is fixed with the last round of mesa updates. Please reopen if it's still an issue.