Bug 247228 - editors/emacs-devel: Update to 2020-06-12 commit 459bd56
Summary: editors/emacs-devel: Update to 2020-06-12 commit 459bd56
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Some People
Assignee: emacs@FreeBSD.org (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-13 05:52 UTC by MANTANI Nobutaka
Modified: 2020-06-13 17:33 UTC (History)
3 users (show)

See Also:
bugzilla: maintainer-feedback? (emacs)


Attachments
Patch of editors/emacs-devel (1.18 KB, text/plain)
2020-06-13 05:52 UTC, MANTANI Nobutaka
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description MANTANI Nobutaka freebsd_committer 2020-06-13 05:52:40 UTC
Created attachment 215511 [details]
Patch of editors/emacs-devel

The update of editors/emacs-devel to 2020-06-01 commit c59e878 breaks package build of editors/apel and this breakage affects all ports that depend on editors/apel.

This breakage can be fixed by the following commit of emacs.

https://github.com/emacs-mirror/emacs/commit/188dc2e5a3cb2de69ec14715ba288ab1e30da6eb

So please update editors/emacs-devel to this commit or later.

I confirmed that packages of editors/emacs-devel and editors/apel were built successfully by poudriere with updated editors/emacs-devel to 2020-06-12 commit 459bd56.
Comment 1 MANTANI Nobutaka freebsd_committer 2020-06-13 05:56:23 UTC
Package build error log of editors/apel with emacs-devel-28.0.50.20200601,2

http://beefy6.nyi.freebsd.org/data/121amd64-default/538269/logs/apel-emacs28-10.8.20190407_2.log
Comment 2 Ashish SHUKLA freebsd_committer 2020-06-13 11:23:07 UTC
Hi,

Thank you for letting us know.

We update editors/emacs-devel every 15 days, is it okay to wait on update until Monday, 15th June, 2020 ?

Ashish
Comment 3 MANTANI Nobutaka freebsd_committer 2020-06-13 14:33:25 UTC
Hi,

Yes, it is okay for me. I will wait until the next update.
Comment 4 commit-hook freebsd_committer 2020-06-13 16:29:07 UTC
A commit references this bug:

Author: jrm
Date: Sat Jun 13 16:28:13 UTC 2020
New revision: 538681
URL: https://svnweb.freebsd.org/changeset/ports/538681

Log:
  editors/emacs-devel: Update to 2020-06-13 commit f4b99b3

  This fixes a build problem with editors/apel.

  PR:		247228
  Submitted by:	nobutaka (earlier commit)

Changes:
  head/editors/emacs-devel/Makefile
  head/editors/emacs-devel/distinfo
  head/editors/emacs-devel/pkg-plist
Comment 5 commit-hook freebsd_committer 2020-06-13 16:29:14 UTC
A commit references this bug:

Author: jrm
Date: Sat Jun 13 16:28:17 UTC 2020
New revision: 538682
URL: https://svnweb.freebsd.org/changeset/ports/538682

Log:
  editors/apel: Unmark as broken after edtiors/emacs-devel update

  PR:		247228
  Reported by:	nobutaka

Changes:
  head/editors/apel/Makefile
Comment 6 Joseph Mingrone freebsd_committer 2020-06-13 16:30:53 UTC
Spoke with Ashish and since there was an update already prepared, we just updated early.  Sorry for the trouble and please let us know if you still have problems.
Comment 7 MANTANI Nobutaka freebsd_committer 2020-06-13 17:33:25 UTC
I confirmed that editors/apel builds successfully with the updated editors/emacs-devel.
Thank you so much!