Bug 247302 - math/p5-Math-GSL: update to 0.42
Summary: math/p5-Math-GSL: update to 0.42
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Li-Wen Hsu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-16 09:51 UTC by Tomohiro Hosaka
Modified: 2020-07-19 14:31 UTC (History)
1 user (show)

See Also:


Attachments
shar (9.75 KB, text/plain)
2020-06-16 09:51 UTC, Tomohiro Hosaka
no flags Details
shar (9.75 KB, text/plain)
2020-07-06 09:12 UTC, Tomohiro Hosaka
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomohiro Hosaka 2020-06-16 09:51:22 UTC
Created attachment 215605 [details]
shar

Expired and removed, but updated to 0.42 to support gsl 2.6.
It's working well.
https://metacpan.org/changes/distribution/Math-GSL
Comment 1 Tomohiro Hosaka 2020-06-16 10:00:48 UTC
https://www.freshports.org/commit.php?category=math&port=p5-Math-GSL&files=yes&message_id=202006051028.055ASD71092072@repo.freebsd.org

We have confirmed that we can build math/p5-Algorithm-KMeans and audio/p5-Audio that have been erased because of this dependency.
I use math/p5-Algorithm-KMeans as well, so it would be nice to get them back in the tree again.
Comment 2 Li-Wen Hsu freebsd_committer 2020-06-16 16:54:43 UTC
Over to the original maintainer. Tomohiro, do you want to be the maintainer of this port?
Comment 3 Tomohiro Hosaka 2020-06-17 01:17:52 UTC
Okay. Yes, it will be a port mainteriner.
Comment 4 Tomohiro Hosaka 2020-07-06 09:12:35 UTC
Created attachment 216243 [details]
shar

I changed the MAINTAINER line. Thanks.
Comment 5 commit-hook freebsd_committer 2020-07-19 14:20:18 UTC
A commit references this bug:

Author: lwhsu
Date: Sun Jul 19 14:19:44 UTC 2020
New revision: 542579
URL: https://svnweb.freebsd.org/changeset/ports/542579

Log:
  Readd math/p5-Math-GSL and update to 0.42

  PR:		247302
  Submitted by:	Tomohiro Hosaka <bokutin@bokut.in>

Changes:
  head/math/Makefile
  head/math/p5-Math-GSL/
  head/math/p5-Math-GSL/Makefile
  head/math/p5-Math-GSL/distinfo
Comment 6 commit-hook freebsd_committer 2020-07-19 14:31:23 UTC
A commit references this bug:

Author: lwhsu
Date: Sun Jul 19 14:30:53 UTC 2020
New revision: 542581
URL: https://svnweb.freebsd.org/changeset/ports/542581

Log:
  math/p5-Math-GSL was readded in r542579

  PR:		247302

Changes:
  head/MOVED