Bug 247369 - [exp-run] update py-sip to 4.19.24, qscintilla2 to 2.11.5 and pyqt to 5.15
Summary: [exp-run] update py-sip to 4.19.24, qscintilla2 to 2.11.5 and pyqt to 5.15
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Many People
Assignee: Port Management Team
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-18 05:05 UTC by Loïc Bartoletti
Modified: 2020-10-06 04:27 UTC (History)
2 users (show)

See Also:
lbartoletti: exp-run?


Attachments
py-sip to 4.19.23 and qscintilla2 to 2.11.5 (21.89 KB, patch)
2020-06-18 05:05 UTC, Loïc Bartoletti
no flags Details | Diff
py-sip to 4.19.23 and qscintilla2 to 2.11.5 (23.21 KB, patch)
2020-06-18 08:49 UTC, Loïc Bartoletti
no flags Details | Diff
py-sip to 4.19.23 and qscintilla2 to 2.11.5 for exp-run (1.57 KB, patch)
2020-06-23 16:32 UTC, Loïc Bartoletti
no flags Details | Diff
py-sip to 5.3.0, pyqt to 5.15 and qscintilla2 to 2.11.5 for exp-run (78.31 KB, patch)
2020-09-01 04:57 UTC, Loïc Bartoletti
no flags Details | Diff
py-sip to 5.3.0, pyqt to 5.15 and qscintilla2 to 2.11.5 for exp-run (v2, as svn diff) (87.06 KB, patch)
2020-09-08 12:51 UTC, Loïc Bartoletti
no flags Details | Diff
py-sip to 4.19.24, pyqt to 5.15 and qscintilla2 to 2.11.5 for exp-run (v3) (77.74 KB, patch)
2020-09-23 18:56 UTC, Loïc Bartoletti
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Loïc Bartoletti freebsd_committer 2020-06-18 05:05:29 UTC
Created attachment 215687 [details]
py-sip to 4.19.23 and qscintilla2 to 2.11.5

Hi there

kde@ would like to ask for an exp-run to update devel/py-sip and devel/qscintilla2 to the newest versions.

Thanks,

Loïc
Comment 1 Loïc Bartoletti freebsd_committer 2020-06-18 08:49:13 UTC
Created attachment 215695 [details]
py-sip to 4.19.23 and qscintilla2 to 2.11.5
Comment 2 Antoine Brodin freebsd_committer 2020-06-20 08:34:52 UTC
The patch looks incomplete (no distinfo change for instance)
Comment 3 Loïc Bartoletti freebsd_committer 2020-06-23 16:32:40 UTC
Created attachment 215886 [details]
py-sip to 4.19.23 and qscintilla2 to 2.11.5 for exp-run

Sorry Antoine,
Here the patch with only pyqt update and devel/py-sip, devel/qscintilla2 distinfo update
Comment 5 Loïc Bartoletti freebsd_committer 2020-09-01 04:57:10 UTC
Created attachment 217685 [details]
py-sip to 5.3.0, pyqt to 5.15 and qscintilla2 to 2.11.5 for exp-run

Antoine,

Here a new patch to an exp-run please.

It fixes failures found previously and adds some improvements.

Thanks.
Comment 6 Antoine Brodin freebsd_committer 2020-09-06 08:57:37 UTC
Please provide a patch that can be applied (problems with at least quick3d part)
Comment 7 Loïc Bartoletti freebsd_committer 2020-09-08 12:51:37 UTC
Created attachment 217820 [details]
py-sip to 5.3.0, pyqt to 5.15 and qscintilla2 to 2.11.5 for exp-run (v2, as svn diff)

Antoine,

Sorry I uploaded the patch from arcanist. Here a patch from my svn with show-copies-as-adds option.
Comment 9 Loïc Bartoletti freebsd_committer 2020-09-23 18:56:29 UTC
Created attachment 218217 [details]
py-sip to 4.19.24, pyqt to 5.15 and qscintilla2 to 2.11.5 for exp-run (v3)

Antoine,

Here a new patch to an exp-run please.

I come back to sip 4 with minor changes.

Thanks.
Comment 10 Guido Falsi freebsd_committer 2020-09-25 11:10:59 UTC
Stumbled upon this while testing calibre update to 5.0.0.

It now requires sip 5.3 though.

Is work to update sip to 5.x already undergoing, or is there some specific problem barring a switch to 5.x?

I could try to help with that if needed.
Comment 11 Loïc Bartoletti freebsd_committer 2020-09-26 06:13:32 UTC
(In reply to Guido Falsi from comment #10)

Hello Guido,

I started the work with sip5: 
- graphics/qgis and graphics/qgis-ltr are ready (sip4 and sip5)
- I have patches for devel/libsavitar and net/libarcus (only sip5)
- I started the work (and upstreamed) on deskutils/calibre (should be available with sip4 and sip5 but to be confirmed)

What is missing? AFAIK, graphics/py-python-poppler-qt5, science/py-veusz, science/scidavis and... py27-sip (from the exp-run).

Why I come back to sip 4:
- Existing ports can use sip4
- I can commit updates from py-sip (4), pyqt and qscintilla2 and we'll be able to look for the sip5 update after this (first) commit.
- And sip5 is python3 only (python2 will disappear, but it's not ready yet)
- There will be a new version in a few months (sip6 with some new deprecations like pyrcc removal.) sip5 seems to be a transitional version.

If the exp-run passes, I commit this and we look for sip>=5 (I'm already on it on another branch)
Comment 12 Guido Falsi freebsd_committer 2020-09-26 09:15:23 UTC
(In reply to Loïc Bartoletti from comment #11)

Thanks for the update. You're really doing a great job here, and sorry if I sounded like downplaying it. I was only looking for some information.

Regarding calibre, with the present tree it fails to build with a sip related error. My impression is version 5.0.0 has a strict requirement on sip 5.3 minimum. But maybe I'm missing something.
Comment 14 Tobias C. Berner freebsd_committer 2020-09-28 17:51:21 UTC
(In reply to Antoine Brodin from comment #13)
Moin oin

devel/py-qt5-sip should simply be marked python:3.5+ -- then all is fine.


mfg Tobias
Comment 15 Loïc Bartoletti freebsd_committer 2020-10-02 16:10:36 UTC
(In reply to Tobias C. Berner from comment #14)

+1, and py-qt5-sip is not yet useful (instead of py-sip).
Comment 16 commit-hook freebsd_committer 2020-10-05 15:50:50 UTC
A commit references this bug:

Author: lbartoletti
Date: Mon Oct  5 15:50:11 UTC 2020
New revision: 551499
URL: https://svnweb.freebsd.org/changeset/ports/551499

Log:
  Update PyQt to 5.15.0, py-sip to 4.19.24 and qscintilla2 to 2.11.5

  - Update PyQt to 5.15.0, py-sip to 4.19.24 and qscintilla2 to 2.11.5
  - Use pypi for PYQT [1]
  - Add devel/py-qt5-sip (Don't use it for now. It will be used in future updates of PyQt with py-sip >= 5)
  - Add missing py-qt5 ports: comms/py-qt5-sensors, devel/py-qt5-location, devel/py-qt5-remoteobjects, net/py-qt5-networkauth
  - Strip libs
  - Refactor *_PATH and *_PORT parts

  [1] RiverBankComputing doesn't offer links to download latest version of some ports

  PR:		247369
  Reviewed by:	tcberner
  Differential Revision:	https://reviews.freebsd.org/D25749
  Exp-run by:	antoine

Changes:
  head/Mk/Uses/pyqt.mk
  head/audio/cadence/Makefile
  head/audio/carla/Makefile
  head/audio/picard/Makefile
  head/biology/py-ete3/Makefile
  head/cad/openscad/Makefile
  head/cad/openscad-devel/Makefile
  head/cad/py-cq-editor/Makefile
  head/cad/py-pyfda/Makefile
  head/comms/Makefile
  head/comms/gnuradio/Makefile
  head/comms/nanovna-saver/Makefile
  head/comms/py-qt5-sensors/
  head/comms/py-qt5-sensors/Makefile
  head/comms/py-qt5-sensors/pkg-descr
  head/comms/py-qt5-sensors/pkg-plist
  head/comms/py-qt5-serialport/Makefile
  head/databases/py-qt5-sql/Makefile
  head/databases/sqlitebrowser/Makefile
  head/deskutils/calibre/Makefile
  head/deskutils/treeline/Makefile
  head/devel/Makefile
  head/devel/eric6/Makefile
  head/devel/git-cola/Makefile
  head/devel/py-qt5/Makefile
  head/devel/py-qt5/distinfo
  head/devel/py-qt5-core/Makefile
  head/devel/py-qt5-core/pkg-plist
  head/devel/py-qt5-dbus/Makefile
  head/devel/py-qt5-dbussupport/Makefile
  head/devel/py-qt5-designer/Makefile
  head/devel/py-qt5-designerplugin/Makefile
  head/devel/py-qt5-help/Makefile
  head/devel/py-qt5-help/pkg-plist
  head/devel/py-qt5-location/
  head/devel/py-qt5-location/Makefile
  head/devel/py-qt5-location/pkg-descr
  head/devel/py-qt5-location/pkg-plist
  head/devel/py-qt5-qscintilla2/Makefile
  head/devel/py-qt5-remoteobjects/
  head/devel/py-qt5-remoteobjects/Makefile
  head/devel/py-qt5-remoteobjects/pkg-descr
  head/devel/py-qt5-remoteobjects/pkg-plist
  head/devel/py-qt5-sip/
  head/devel/py-qt5-sip/Makefile
  head/devel/py-qt5-sip/distinfo
  head/devel/py-qt5-sip/files/
  head/devel/py-qt5-sip/files/LICENSE
  head/devel/py-qt5-sip/pkg-descr
  head/devel/py-qt5-test/Makefile
  head/devel/py-qtbuilder/
  head/devel/py-qtbuilder/Makefile
  head/devel/py-qtbuilder/distinfo
  head/devel/py-qtbuilder/pkg-descr
  head/devel/py-qtconsole/Makefile
  head/devel/py-sip/distinfo
  head/devel/py-spyder/Makefile
  head/devel/qscintilla2-qt5/distinfo
  head/devel/tortoisehg/Makefile
  head/devel/vitables/Makefile
  head/emulators/fs-uae-launcher/Makefile
  head/games/anki/Makefile
  head/games/py-mnemosyne/Makefile
  head/graphics/py-python-poppler-qt5/Makefile
  head/graphics/py-qt5-svg/Makefile
  head/graphics/py-visvis/Makefile
  head/graphics/qgis/Makefile
  head/graphics/qgis-ltr/Makefile
  head/graphics/qtqr/Makefile
  head/graphics/rapid-photo-downloader/Makefile
  head/lang/py-qt5-qml/Makefile
  head/math/convertall/Makefile
  head/math/octave/Makefile
  head/math/rpcalc/Makefile
  head/misc/orange3/Makefile
  head/misc/py-QSpectrumAnalyzer/Makefile
  head/misc/py-qt5-demo/Makefile
  head/misc/urh/Makefile
  head/multimedia/openshot/Makefile
  head/multimedia/py-openlp/Makefile
  head/multimedia/py-qt5-multimedia/Makefile
  head/multimedia/py-qt5-multimedia/pkg-plist
  head/multimedia/py-qt5-multimediawidgets/Makefile
  head/multimedia/py-qt5-multimediawidgets/pkg-plist
  head/net/Makefile
  head/net/py-qt5-network/Makefile
  head/net/py-qt5-network/pkg-plist
  head/net/py-qt5-networkauth/
  head/net/py-qt5-networkauth/Makefile
  head/net/py-qt5-networkauth/pkg-descr
  head/net/py-qt5-networkauth/pkg-plist
  head/net-mgmt/nagstamon/Makefile
  head/print/py-frescobaldi/Makefile
  head/print/py-qt5-printsupport/Makefile
  head/science/code_saturne/Makefile
  head/science/py-veusz/Makefile
  head/sysutils/angrysearch/Makefile
  head/textproc/py-qt5-xml/Makefile
  head/textproc/py-qt5-xmlpatterns/Makefile
  head/textproc/retext/Makefile
  head/www/onionshare/Makefile
  head/www/py-qt5-webchannel/Makefile
  head/www/py-qt5-webengine/Makefile
  head/www/py-qt5-webengine/distinfo
  head/www/py-qt5-webengine/pkg-plist
  head/www/py-qt5-webkit/Makefile
  head/www/py-qt5-webkitwidgets/Makefile
  head/www/py-qt5-websockets/Makefile
  head/www/qutebrowser/Makefile
  head/x11/py-qt5-opengl/Makefile
  head/x11-toolkits/Makefile
  head/x11-toolkits/py-qt5-chart/Makefile
  head/x11-toolkits/py-qt5-chart/distinfo
  head/x11-toolkits/py-qt5-gui/Makefile
  head/x11-toolkits/py-qt5-gui/pkg-plist
  head/x11-toolkits/py-qt5-quick/Makefile
  head/x11-toolkits/py-qt5-quick/pkg-plist
  head/x11-toolkits/py-qt5-quick3d/
  head/x11-toolkits/py-qt5-quick3d/Makefile
  head/x11-toolkits/py-qt5-quick3d/pkg-plist
  head/x11-toolkits/py-qt5-quickwidgets/Makefile
  head/x11-toolkits/py-qt5-widgets/Makefile
Comment 17 Loïc Bartoletti freebsd_committer 2020-10-06 04:27:53 UTC
Committed, thanks for the exp-run antoine!