Bug 247374 - emulators/wine-devel: crashes on startup
Summary: emulators/wine-devel: crashes on startup
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: amd64 Any
: --- Affects Only Me
Assignee: Gerald Pfeifer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2020-06-18 10:16 UTC by Oleksandr Kryvulia
Modified: 2020-06-22 06:53 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleksandr Kryvulia 2020-06-18 10:16:00 UTC
Running latest wine-devel from ports on CURRENT r362091 ends with:

002c:err:seh:raise_exception Unhandled exception code c00000fd flags 0 addr 0x7bc6d731
0024:fixme:actctx:parse_depend_manifests Could not find dependent assembly L"Microsoft.Windows.Common-Controls" (6.0.0.0)
0024:err:seh:raise_exception Unhandled exception code c00000fd flags 0 addr 0x7bc6d731
Comment 1 Gerald Pfeifer freebsd_committer 2020-06-18 11:32:37 UTC
Does this also reproduce on a release or a stable branch? 

-CURRENT is, well, -CURRENT, and also not accessible to me (and not really
intended for end users to be fair). Happy for you to give it a try, but it
probably will require you to dig into it a bit deeper, realistically.
Comment 2 Alex S 2020-06-18 14:54:05 UTC
This is likely related to the l_addr issue and the subsequent series of back-and-forth patches. See this commit: https://source.winehq.org/git/wine.git/commitdiff/f728a5f3f9a4f1cad64aa3a1d3e9951940b0955c.
Comment 3 Oleksandr Kryvulia 2020-06-19 10:03:58 UTC
With that patch wine-devel works, waiting for port update. Now have some problems with cyrillic fonts, but I'll fire a separate bug.
Thank you!
Comment 4 commit-hook freebsd_committer 2020-06-22 06:53:24 UTC
A commit references this bug:

Author: gerald
Date: Mon Jun 22 06:52:43 UTC 2020
New revision: 539797
URL: https://svnweb.freebsd.org/changeset/ports/539797

Log:
  Update to Wine 5.11.  This includes the following changes:
   - Wine Mono engine 5.1.0 provides WpfGfx library support.
   - More work on the separate Unix library for NTDLL.
   - Beginnings of a NetIO kernel driver implementation.
   - Initial support for the Print Ticket API.
   - Various bug fixes.

  Among others my fix from files/patch-dlls_ntdll was accepted upstream,
  so remove it here.

  Two files have moved from the Staging patchset to the general tree, so
  package them across the board.

  This snapshot should also fix issues on recent -CURRENT. [1]

  PR:		247374 [1]

Changes:
  head/emulators/wine-devel/Makefile
  head/emulators/wine-devel/distinfo
  head/emulators/wine-devel/pkg-plist